psychopy.org | Reference | Downloads | Github

Error when opening PsychoPy app

I’ve been having an issue with opening the PsychoPy app on a Mac with the most recent IOS. It was working fine before, but now every time I go to open it I get a pop up that says “PsychoPy Error”. When I open the console, I see this error message: Apr 13 12:22:50 MWFVFYX0KYHV2F diagnosticd[4051]: System mode client started - Console (5390) - mode: 0xb, filter: “”
Apr 13 12:22:55 MWFVFYX0KYHV2F com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
Apr 13 12:23:41 MWFVFYX0KYHV2F Console[5390]: BUG in libdispatch client: vnode, monitored resource vanished before the source cancel handler was invoked { 0x60000111ea80[source], ident: 12 / 0xc, handler: 0x7fff4f5fa81b }
Apr 13 12:24:25 MWFVFYX0KYHV2F systemstats[56]: assertion failed: 18G4032: systemstats + 673819 [40E59F12-7885-33A9-913A-6EA5B24AC9AC]: 0x5
Apr 13 12:24:47 MWFVFYX0KYHV2F com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x1000000d.PsychoPy3[5404]): Service exited with abnormal code: 255
Apr 13 12:24:52 MWFVFYX0KYHV2F syslogd[42]: ASL Sender Statistics
Apr 13 12:24:55 MWFVFYX0KYHV2F kcm[5413]: DEPRECATED USE in libdispatch client: Setting timer interval to 0 requests a 1ns timer, did you mean FOREVER (a one-shot timer)?; set a breakpoint on _dispatch_bug_deprecated to debug

I’ve tried uninstalling and reinstalling PsychoPy and python, updating my computer, and simply restarting it, but nothing has worked. When I try to run the code included in the cleaning preferences and app data (https://www.psychopy.org/troubleshooting.html), I get an error saying that ~/.psychopy3 is not in the directory. Any suggestions on how to troubleshoot further?

1 Like

I had a very similar issue, and it was solved by removing the prefs (thanks for the link).

If you don’t have any special setups on your mac, you’ll prob find the .psychopy folder right in your user root. So open a Terminal window and type ls -A to see hidden files and folders. If .psychopy3 is there, you can just cd into it: cd .psychopy3 . Then again ls -A and you should see the offending .cfg -files and be able to remove them (rm appData.cfg userPrefs.cfg).