Error "font not found locally" in the latest release of Psychopy

OS: Mac OS 10.14.6
PsychoPy version: 2021.1.2
Standard Standalone?: yes

Question description:
I just updated the latest Psychopy (2021.1.2) on my Mac. When I run my experiment (which was built on Psychopy 2020.2.10), I found this notice — “Font '宋体’ not found locally, will attempt to retrieve from Google Fonts when this experiment next runs”. Other fonts have the same problem, no matter they are Chinese fonts or English fonts.


This error has never appeared in the 2020.2.10 version. All the fonts have already installed locally by default.
How should I fix this? Thank you very much!

p.s. This is my first time posting on this forum and English is not my mother tongue, please forgive me if I posted anything inappropriate.

1 Like

Usually this alert isn’t anything to be worried about - it’s just a warning that PsychoPy will connect to the internet and attempt to get a font from Google. However, if you have 宋体 installed locally, then this suggests that PsychoPy isn’t finding it.

When you open Font Book on your Mac, does the name of the font appear as 宋体 or is it translated to latin characters (e.g. Song Ti)? It may be that PsychoPy is looking for a font name different than the name it’s installed under. If so then you should type the font name as it appears in Font Book.

This was most likely the case in the previous version too, it’s just that the warning hadn’t been added yet - your text was probably being displayed in Arial (the default font).

Thank you very much for your answer.
First, 宋体 and other daily used fonts have already installed on my Mac. In my Font Book, all the fonts of Chinese characters are in their Chinese name instead of in Latin characters (in the following picture, highlighted in blue). Similarly, the font names for English text are in Latin characters.

Second, you mentioned that the text was probably being displayed in Arial in the previous version. However, it was being displayed in 宋体, because if it was in Arial, the text would be displayed disorderly like this in the following picture.

Third, I would like to revise one mistake in my yesterday’s post, which is “Other fonts have the same problem, no matter they are Chinese fonts or English fonts.” In fact, if I use the Eglish font like Times New Roman, the font alert will not appear.

So now I wonder if this alert has something to do with the compatibility of language. Maybe the PsychoPy is more compatible with English. By the way, the system language of my Mac is Chinese. I do not know if it has something to do with my system language.

I am very grateful for your time and help. Looking forward to your reply :smile:

Ah I see, it’s very strange that even Times New Roman isn’t showing up… I’ll try setting my PC language to Chinese and see if I can replicate this error and find its source!

What happens if you set the font to be a Google font which you don’t have installed? If you use the names of any fonts here:

and they aren’t installed locally, it will install them from online, so if that works then we can narrow it down to definitely being a bug with local font searching.

Thank you very much for your reply.
I tried your suggestion. Here are the results:
Scenario 1: set the font to be a Google font which I don’t have installed.
I tried three Chinese fonts and three Latin fonts (6 in total). It seems like they cannot be installed online because the display is disordered. (showed in the following picture)

Scenario 2: I downloaded and installed 2 of the fonts mentioned in Scenario 1, which are Long Cang and Stick, for Chinese and Latin each. When I run the experiment, the font of the text matched with what I typed in the box. (showed in the pictures below)

The alert exists in both scenarios. Only fonts like Times New Roman and Arial do not trigger the alert.

Thank you very much again for your time and help. :grinning:


Arial and Times New Roman do not trigger the alert.

It’s good that Arial and Times New Roman don’t trigger the alert as they shouldn’t - the Google Fonts (not installed) should trigger the alert but display, the Google Fonts (installed) should display without the alert. Is this all in 2021.1.x? Could you elaborate on what you mean by “the display is disordered” in Scenario 1?

It is all in v2021.1.2. Sorry for my vague expression. :cry: “The display is disordered” means that the Chinese characters showed on the screen are incomplete. Each character just displays half of itself.