psychopy.org | Reference | Downloads | Github

ERROR avbin.dll failed to load


#1

Hello,

I tried running an experiment and the following error pops up:

I downloaded avbin from this website, using the windows 64 bit file for my Microsoft surface book. Any suggestions on how I can resolve this issue?

I appreciate any help, thanks!


PsychoPy 1.84.2 crashes in previously-running script
#2

Hi there,
A couple of users have reported similar things and I’m keen to work out what’s going on, but none of the message above should be causing your experiment to quit (unless you have movies in it that are using avbin).

Do any experiments run? e.g. can you run the demos?


#3

Hi Jon,
I have a similar problem. It started after I upgraded from version 1.8.2 to 1.85.6 standalone a few hours ago.

I used the builder to design a very simple experiment of showing a sequence of pictures. It gives me the error after the 4th picture presentation. The pictures are not the problem.

I tested the demos. Even the helloworld does not run properly. This is the output:

(x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\basic\hello_world.pyc’

Running: C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\basic\hello_world.py

2.3410 ERROR avbin.dll failed to load. Try importing psychopy.visual
as the first library (before anything that uses scipy)
and make sure that avbin is installed.
2.3455 WARNING Monitor specification not found. Creating a temporary one…

I have avbin.dll in SysWOW64 (no advin file in System32 folder, referring to Avbin.dll fail to load)

Your help is appreciated and thank you for building Psychopy.
Anna


#4

I tried the hello_world.py with 1.85.4, 1.85.3, and 1.85.2. (windows 10, standalone_win32).
After 3 sec waiting, 1.85.4 and .3 gave the same error as .6 (above).
1.85.2 didn’t give the error but showed this warning:

Problem compiling: [Errno 13] Permission denied: ‘C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\basic\hello_world.pyc’

Running: C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\basic\hello_world.py

2.2289 WARNING Monitor specification not found. Creating a temporary one…


#5

Hi Jon,
I see that you mentioned because the advin error is not fatal for hello_world, this is not an issue https://github.com/psychopy/psychopy/issues/1483 and the issue is limited to using movies. I am not using movies but I want to show a sequence of 10 pictures in a loop. The error is fatal in my case (after showing a few pictures). What do you recommend using to go through the error?

Also my graphic card is update and works fine. I don’t think that is causing the problem (Avbin.dll fail to load). Do you have a test for reassuring that?

Thanks for your help in advance
Anna


#6

I’ll just reiterate that I’m confident that the avbin error is a red-herring. I’m sure there’s a different problem in your case but it’s hard to know what that is if the only error you see is the avbin one


#7

Hi Jon,
I have the same error in my experiment and it indeed does not prevent the experiment from working.
However, after a few trials, the error is printed too many times and the experiment crashes.

It seems like there is a capacity for the pop up window (that prints the errors and pops up at the end of the experiment), because different errors\or using the print command too many times throughout the experiment, causes the same problem.

Any suggestions on how I can resolve this issue?
Thank you very much!
Paz


#8

I’m seeing a similar error (see below), initially in a stroop-type task I created, but then also with the stroop demo. No such error with the mental rotation demo. It’s causing the stroop tasks to end prematurely.
I’m no coder, so any lay explanation and/or solution would be highly appreciated!
Thanks
Alice

Running: C:\Users\Alice\Documents\PsychoPy-1.85.6\PsychoPy-1.85.6\psychopy\demos\builder\stroop\stroop.py

pyo version 0.8.7 (uses single precision)
39.1364 ERROR avbin.dll failed to load. Try importing psychopy.visual
as the first library (before anything that uses scipy)
and make sure that avbin is installed.
112.3559 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

112.7185 WARNING t of last frame was 30.95ms (=1/32)
112.7560 WARNING t of last frame was 37.52ms (=1/26)
112.7874 WARNING t of last frame was 31.42ms (=1/31)
112.8187 WARNING t of last frame was 31.32ms (=1/31)
112.8568 WARNING Multiple dropped frames have occurred - I’ll stop bothering you about them!
115.8622 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

Module import order affects MovieStim3 function