| Reference | Downloads | Github

PsychoPy 1.84.2 crashes in previously-running script

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 1.84.2
**Standard Standalone? Yes
The experiment was previously working fine and the output was correct. However when I have tried to test it on a participant the experiment gets through the instructions, block 1, block 1 questions and the break fine, but when starting block 2 it starts and does a few trials and then throws the error labelled error 1 and 2.

When I have been playing around testing the experiment to try and get it working, I have also received another error in the third picture. Not sure if this provides more information.
I am not sure why this is not working and have been looking at theads on this website to see if anything can help.
Below is the script of the experiment. I have three versions of the experiment with the same skeleton, just the stimuli that changes and all of them show the same error.

I have looked at previous thread (PsychoPy 1.84.1 crashes in previously-running script) and have checked the Windows (C:0 > Program Files (x86) >Psychopy2 > DLLs> and the documents in there end in either .dll or .pyd like I assume they should.

Any help would be appreciated. Thank you!

PS: I have another experiment with two blocks that is a very basic LDT and this is running fine, using the same computer and psychopy version.
code1.xlsx (35.9 KB)

1 Like

Additional error.

Not using videos or pictures in my experiment but still getting the error. Only using words and one symbol. Not sure if this info helps.

  • Sentence (one routine) // Word> Word (other routine) = all in the same loop

I can’t actually read your error messages. If you select the text in the dialog and right-click you should be able to copy that rather thana screenshot of the whole screen?

One error looks like the avbin thing that is mentioned here:
ERROR avbin.dll failed to load
and maybe we can debug that one in that thread rather than here. If you have an experiment that works and another that doesn’t maybe you can help us narrow down the difference between them?

The other message might be one about text memory. That’s might be a problem that’s now fixed in the most recent release (actually a bug in one of the dependent libraries, and we’ve now included a newer version so download the whole Standalone package):

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 1.85.6
**Standard Standalone? Yes


I have a similar problem: My PsychoPy experiment runs fine on my Windows 7 PC, but comes up with the same error messages that NDM’s experiment showed when I try to run it on my Windows 10 laptop (which I need to use for the experiment since it’s portable).

These are the error messages:

File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\”, line 646, in flip
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\”, line 744, in draw
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\font\”, line 561, in draw
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\text\”, line 858, in draw
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\graphics_init
.py", line 560, in draw
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\graphics_init
.py", line 492, in
(lambda d, m: lambda: d.draw(m))(domain, mode))
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\graphics\”, line 316, in draw
glDrawArrays(mode, starts[0], sizes[0])
WindowsError: exception: access violation writing 0x00000000

The script is not crashing and apparently is recording data, but it seems to either record more trials then intended or fewer trials then intended. Because of that, the data is then not processable. The experiment is a joystick adaptation task, where participants shoot targets and adapt to a visual rotation of the cursor.

The PsychoPy version I am using is the most recent one (v 1.85.6) on both computers.

The experiment was written in PsychoPy v.1.76.00, but since it is working fine on the Windows 7 PC, I don’t think this is an issue.

I have attached screenshots of the computer info screens.

Any help would be appreciated, thanks in advance!!

rotationseq_staircase_setcount.xlsx (8.9 KB)
VMIreal_staircase_setcount.psyexp (29.4 KB)