psychopy.org | Reference | Downloads | Github

Avbin.dll fail to load

Hi everyone…
Recently I was running the psychopy for my research. I use BART in my study and run this program using computer in the lab. This program is perfectly fine when i run by using my laptop and it does not working and those massage appear when i use the lab computer to run the BART. I am really hoping that someone could help me on how to fix this problem
Thank you

My guess is that you need to update your graphics card drivers on the lab computer

If your are using Windows, please check the location of the avbin dlls.

avbin64.dll should be in C:\Windows\System32
avbin.dll should be in C:\Windows\SysWOW64

Yes, the 64bit dll should be in system32 and the 32bit dll should be in SysWOW64… The avbin installer places the dlls in the wrong folders.

Also, make sure that there is only one avbin.dll and only one avbin64.dll on your system. Don’t keep a copy in your project folder.

Best,
Hubert

I am also getting this same error but the solution offered by hubertv can’t work as I only appear to have 1 avbin.dll on my machine. I am running psychopy on 2 machines and get the error on both.

First machine: 32-bit windows desktop, psychopy version 1.85.3, avbin.dll is in C:\Windows\System32.
Second machine: 64-bit windows desktop, psychopy version 1.85.3, avbin.dll is in C:\Windows\SysWOW64.

This error has only popped up since I updated psychopy to 1.85.3. It isn’t causing scripts to crash that I can tell, the error just appears at either the start or end of running experiments, but it’s a bit concerning in case it will affect future tasks.

The error message about avbin is irrelevant if you’re not using videos. Don’t worry about it - it will not be causing any other damaging effects.

The original post has another problem which is most likely caused by broken graphics card drivers that need updating.