Data not saved due to Pavlovia Gitlab error

URL of experiment:
Description of the problem:
EasyEyes is built atop of PsychoJS. I ran an EasyEyes experiment in class with 20 students. I gave them the study URL (above), which they typed into their browsers. It worked fine for nearly everyone. One student, on a MacBook Pro got this fatal PsychoJS error (see screenshot), which is new to me. My hunch is that Pavlovia’s Gitlab couldn’t handle two instances of PsychoJS (i.e. two students) uploading data at once. Is that right? Ideally PsychoJS would pause and try again instead of just dying without saving the data.
P.S. When I downloaded all the data I did find a 606KB CSV data file for CrazyForestPear249, so it appears that most of her data were saved. Phew! Even so, the fatal error is worrying. If she’d been recruited online she wouldn’t be sent back to Prolific with a completion code, and might not get paid.

Unfortunately we encountered the following error:
• when uploading participant’s results for experiment:
• when saving data from a previously opened session on the
• unable to push data with key:
CrazyForestPear249 Threshold 2022-02- to GitLab repository: Cmd(‘git)
failed due to: exit code(128) cmdline: git add
02-02 16h02.27.967.csv stderr: "fatal: Unable to create
"/data/run/denispelli/perception2/.git/index.lock’: File
exists. Another git process seems to be running in this
repository, e.g. an editor opened by ‘git commit’. Please
make sure all processes are terminated then try again.
If it still fails, a git process may have crashed in this
repository earlier: remove the file manually to continue.’
Try to run the experiment again. If the error persists, contact the
experiment designer.

I agree that this is concerning and has happened before.

I think that it may be better when you save to database instead of CSV because fewer files are being saved to gitlab.