psychopy.org | Reference | Downloads | Github

Custom Ratingscale Code Bug

Stumbled upon a possible bug today as I tried to create a cutom rating Scale in the Builder.
The problem appeared as I typed the pos(0.0,0.0) attribute at last in the custom textbox. A compiler error occured telling me that the next textstimuli (under the ratingscale) was invalid.

It seemed to be the case, that the builder compiler did not recognize that the “pos(0.0,0.0)” still needs a closing bracket.
When I switched pos(0.0,0.0) to the forelast position, everything worked fine and the compiler did succesfully detect all parameters.

Regards

1 Like

Did you really put pos(0.0, 0.0)? That has a missing = sign, should be:

pos=(0.0, 0.0)

If there’s still a problem I’ll look into it.

Sorry was writing on mobile.

I correclty assigned the tupel with = of course.

Ok, yes this is a bug, will fix eventually.

Workarounds: 1) don’t have pos=(x,y) be the last thing, or 2) use brackets: pos=[0,0]

I have exactly the same problem. When I’m trying to customize a rating scale in Builder (e.g. markerColor, textColor), regardless of the position (first, in the middle, last) an error message says that the next line in the script is invalid. Wonder if there’s a solution since then.

Thanks a lot!

I think I also have the same problem. In builder 2020v ratingscale won’t change the textColor. Its just stuck on light grey. Do you have a solution?