psychopy.org | Reference | Downloads | Github

Csv file is missing seperator for reactiontimes bigger than one second

Dear all,
I created a reaction time experiment and in the output file everything looks good besides that value bigger 1sec have an awkward format if I want to read it with excel or python.
It looks like just the comma went missing.
In the screenshot in the first and third line of data had this for example.
Do you have an idea what I could try to solve this problem?
I looked in the forum but didn’t see something similar.
On workaround could be to take these numbers and make a point after the first number, but this would be just guessing…
OS: Win10/PsychoPy 3

I really would appreciate any ideas
Thank you
Laura

2019-10-30_14h53_06

the dots are just format from excel.
the actual number is: 174065473547671. Without any format

We probably need to see the raw text output, before Excel has had a chance to mangle it. Can you just open the file in a simple text editor and paste in a relevant section here?

These issues are usually to do with locale settings in your operating system (e.g for countries where a comma is used as a decimal separator) but we probably really need to see the raw text to be sure.

1 Like

Dear Michael,
I have tried an other computer and that worked normal.
Thank you!
Laura