Completed URL not working in PsychoPy 2022.1.1

After updating to the new version, the completed URL adds the ( before the Qualtrics link, which causes the link to be invalid. I’ve used PsychoPy and Pavlovia a lot and never had any problem with Completed URL in the past. Below is what I have in the Setting:

Here is the link participants have been redirected to:


Please let me know if there was any change to the 2022.1.1 version that we need to do this process differently. I really appreciate any help you can provide.

You should probably delete the complete URL

While that should work, I’d recommend putting a $ at the start of the completed URL and enclosing it in double quotes to see if the code version helps.

Thanks for the suggestion @wakecarter, does it look like below because now the experiment is stuck at “initialising the experiment…”

Have a look at Developer Tools to find out what syntax error is stopping your experiment.

Has anyone solved this problem? I have the same error: “run-pavlovia-org” is inserted at the beginning of the completed URL. The program runs and then the user is redirected to a non-existent site Entering the URL as $“https://the.completed.url” does not fix the problem (the program runs but the user still ends up at a non-existent site). I’m running v2022.1.1 on mac os x 12.2.1.

Hi Everyone,

I need to test this myself my end. But as a temporary work around for your experiment please could you try adding a code component to the last routine in your experiment, set code type to “JS” and in the end routine tab use
psychoJS.setRedirectUrls(YOUR COMPLETION URL)

Hopefully this helps,


Yes, that worked for me! Thanks.