psychopy.org | Reference | Downloads | Github

Changing size of content that is displayed full-screen on a second monitor

OS: Windows 10
PsychoPy version 1.85.6
**Standard Standalone? ** Yes

We were trying to use the monitor in the fMRI scanner as a second monitor to run our psychopy experiment.

However, a problem with the scanner’s monitor is that it cannot display all the content within the 19201080 monitor of our computer. This is because whereas the scanner’s monitor has resolution 19201080, the edges of the monitor are partially covered by a frame and the effective display size equals 1688* 1080 instead of 1920*1080. In other words, contents on the far left and right sides of the computer screen will not be visible to the participants on the monitor inside the scanner (as they will be covered by the monitor’s frame).

Therefore, we are wondering if there is a way to “shrink” the displayed content on the second monitor inside the scanner, without exiting full-screen mode, since otherwise it might be distracting for the participants. Is it possible to achieve it by changing the monitor resolution settings, either in PsychoPy or in Windows?

The only way I can think of to solve this problem is to change the size of the displayed content in PsychoPy; that is, to use texts and images that are smaller. However, this approach is not ideal, because it will require great effort in adjusting the polygon positions (which have been tuned to the current size and position of the images and texts).

Thank you so much for helping us solve the issue!

Sincerely,

Yi

Hello, I am having a similar problem, not sure it’s directly related here but wanted to ask whether you were able to solve it or not.

When I run my experiment I also lose the stimuli on the outer edges of the screen, as if the edges are cropped - it doesn’t display the full screen.

I have also tried different settings, with different Units, Experiment Settings, in different monitors. As I’m using MovieStim3 within my trials as well, I have also tried different backends, thinking maybe it’s related to the videos or something. None of these helped so far.

I would be glad to hear any solutions you might offer!

This is entirely about setting units appropriately. Look at the reference here:

http://www.psychopy.org/general/units.html

If you still have issues, show us your exact problem, providing screenshots of your stimuli and the settings you have applied for them, and then we can suggest how to fix it.

Thank you Michael, sorry for posting twice, I deleted the other one.

Actually I have tried all units, I got the exact problem with each alteration. I’ve read through the instructions about the units a couple of times but maybe I’m missing a point.

And I missed mentioning an important point; I didn’t have this problem until recently. I didn’t change any screen/window settings etc, the only activity I did was copying the file and rearranging some routines in the flow.

This is how the current screen looks. The video was supposed to cover the whole screen, but it looks strangely framed by the normal gray layout:

The respective window settings are:
win = visual.Window(
size=[1680, 1050], fullscr=True, screen=0,
winType=‘pyglet’, allowGUI=True, allowStencil=False,
monitor=‘testMonitor’, color=[0,0,0], colorSpace=‘rgb’,
blendMode=‘avg’, useFBO=True,
units=‘height’)

This was taken from macOS Mojave v10.14.5. I have got the same screen with Windows 10.

Please let me know if I missed including any other related information.

Thanks in advance!

We need to see the settings of the movie stimulus. You could try setting the size of the movie to be 2 in “height” units, to maximise the amount of screen space covered without any cropping occurring.

The other place where things could go wrong is in the monitor settings for your screen called testMonitor. Maybe that doesn’t match what you expect.

This is what happens when I apply this. Looks even more weird:

Here are the respective settings I use for the movie stimulus:

Here are the respective settings I use for Monitor & Experiment Screen:

I have tried all units & backends and their combinations for Movie Stimuli. It doesn’t work. Besides, the same problem applies in text stimuli as well:

Here are the settings for text stimulus:


For Experiment Screen Settings, the problems remains no matter I set the screen 0 or 1; check or uncheck full-screen window and try with different units. What am I missing?

You don’t give the pixel dimensions of your movie, so I don’t know if the aspect ratio matches the screen, but what happens if you set the size of the movie to be 1680 × 1050, in pixel units?

Thank you for the suggestion; that worked with Windows, but not with Mac. Since I will conduct my experiment in Windows anyways, the urgency of the problem eased off, my experiment is working properly.

However, it remains the same with Mac, I think there is another issue that has something to do with Macs. I have read other posts about various displaying errors on Mac, maybe this is one of them as well…