Changes made to exp. script not appearing in experiment

I have pushed changes to my experiment script and I can see on Gitlab that changes have been made; however, when I run this same experiment on Pavlovia, I get the old version of the script for some reason and the changes are not reflected in my experiment. I have had this issue before but it has not persisted for more than 30 mins. I have made these script changes hours ago now. Is this a site-wide issue, by any chance?

I am using jsPsych to code my experiment, in case that’s important.

Many thanks,

1 Like

Same problem here. I can see from the browser developer tool (F12) that pavlovia runs code that is by far older than my newest commit to GitLab.

Pavlovia runs code that is at least since 48 mins deprecated.

Have you tried a hard refresh of your browser (Ctrl-Shift-R in Chrome)?

1 Like

Thanks a lot for your hint! :slight_smile: Didn’t know about hard-refresh until now

In firefox, I did a hard refresh while being on some page I don’t remember exactly by now (it was either or pavlovia(dot)org/GaebChri/crosscodal-surfinfoloss (page of my experiment). Then it still ran the old script.

Then I ran it in MS Edge -> ran current script

Then did hard-refresh on pavlovia(dot)org/dashboard again -> Firefox now also runs current script.

Conclusion: You were probably right that the browser is the source for the error and the hard-refresh on pavlovia(dot)org/dashboard probably has fixed it :+1:

Thank you so much for your quick help!

Short question: Is a hard-refresh specific for a certain webpage? So should I do it while being on for it to work?

I usually do it on the experiment run page – since I’ll have just run the experiment, pushed an edit and now want to run it again. I think it will also work on the experiment home page and possibly also the dashboard.

1 Like