| Reference | Downloads | Github

Cedrus Button Box - "no attribute" error

I am trying to get a simple GO NO-GO task to work using a Cedrus RB-740 button box. However, I can’t seem to get the button box to work - I get the following error message when I attempt to run the experiment:

Traceback (most recent call last):
File “D:\Google Drive\Startle\Tasks\GoNoGo\GNG PsycoPy\GNG”, line 375, in
if ResponseBox.status == STARTED and t >= frameRemains:
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyxid\”, line 433, in getattr
return getattr(self._impl, attrname)
AttributeError: ‘ResponseDevice’ object has no attribute ‘status’

I have read several threads on getting these button boxes to work, but none of the solutions I’ve come across have worked. Any advice is greatly appreciated. I’m fairly new to Psychopy - but am motivated to learn!

OS Win 10
PsychoPy version (e.g. 1.84.x): 1.85.1
Standard Standalone? (y/n) If not then what?: y

@Mattprice Were you able to solve this problem? I am getting the same error message (AttributeError: ‘ResponseDevice’ object has no attribute ‘status’) but haven’t been able to find a solution. Thanks!

For anyone stumbling upon this later:

I had the same issue and was able to resolve it by modifying the pyxid definition to include a status attribute. Seems like the development team probably had a pre-release of pyxid :wink:

Drop this modified version into your site-packages (C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyxid\ in the original post) (14.1 KB)


Any idea where this files lives on Mac? I have the same error and would like to see if this workaround can resolve it. Thanks.

Yup! On a Mac, assuming you used the standard bundled install image lives at:


To get there, you can open finder, press Cmd+Shift+G, and paste this path. If you want to get there through the graphical interface, go to /Applications, right click on PsychPy2 and select “Show contents”, then follow the rest of the path.

edit: I originally did this fix on a mac, so you should be good to go.

1 Like

It worked! Thank you for your help. This fix took me over two months!

Thank you! This also did the trick for me. Can’t thank you enough!!

Replacing this file worked for me too. I’m using 1.85.1

I am also trying to install a response box, once this modified version is installed (on a Mac), should it simply be plug and play? or is there code also required? Thanks