psychopy.org | Reference | Downloads | Github

Can't sync or run experiments online by using builder

All of a sudden, I cannot sync my experiments to Pavlovia or run them online from the PsychoPy builder anymore. Here is the message that I get:

I am using the latest PsychoPy release (2020.1.3), I tried reinstalling the app, installing git and python git, but nothing seems to help. I also didn’t change any settings that could cause this behavior. My experiments are currently active and running so I rather not share the URLs publicly.

Anyone? I have my online experiments up and running, but I can’t seem to communicate with them anymore, at least not via PsychoPy builder. It doesn’t matter whether I create a completely new experiment or try to sync an old one, the problem is the same. I need to correct some minor bugs, so I would really appreciate it if someone could help me out.

It seems that for some reason PsychoPy can’t access Git anymore - at least that’s what the console is saying (“gitpython and a git installation required for getProject()”). I do remember that I used “sfc /scannow” command to try to solve some other PC connected issue. Could this be the source of the problem? If so, what can I do?

@apitiot @jon any ideas?

I have no idea. PsychoPy standalone ships with its own copy of git. If that can’t be found all I can imagine is that your path variable has become broken (although if you resintalled standalone then it would have at least rtied to fix that). What is your Path environment variable right now (in system properties > advanced)?

Here’s the screenshot of my PATH variable:

image

Well, that’s interesting. The issue seems to be gone now even though I haven’t done anything in particular :neutral_face: When I tried to sync the experiment, there was no error message anymore, and PsychoPy asked me to “Choose/create the root location for the synced project”. Then it synced as it nothing ever happened. Weird. Thank you anyways @jonathan.kominsky and @jon for trying to help me out.