"Attempting to measue frame rate of screen" stuck

When even I try to run an experiement I get a grey screen with the message “attempting to measure frame rate of screen, please wait” and nothing happens, it just gets stuck. I tried opening a new project with just one routine the says “hi” and it’s not working. If I don’t brutally end it, it ends with this error:

OS : Win 10
PsychoPy version : v2023.2.1
Standard Standalone? I’m not sure what is meant
What are you trying to achieve?: a working basic experiment

1 Like

Hey! could you solve it? Same problem here
version 2023


I have the same problem…

1 Like

We have the same problem using Standalone PsychoPy 2023.2.2 on Windows 10 and a mimimal experiment (just one text component). On some computers, the message “attempting to measure frame rate of screen, please wait” stays for a few seconds and the experiment works. On others, it stays for minutes until we forcefully close PsychoPy (Escape does not do anything). Any help would be appreciated.

1 Like

We could fix the problem by 1) switching the BIOS setting Video/Primary Display from “Auto” to “Intel HD graphics” (even though there was only one video controller, so it is unclear what “Auto” did differently) and 2) updating the driver of the Intel HD graphics 2500 chip to version on Windows 10.0.17763. Now the frame rate measurement takes 1-5 seconds, not forever.

It looks like your frame rate is somehow being reported as <0.5 frames per second, most likely something went wrong during the test and made it take ages to sample a particular frame. If you uncheck “Measure frame rate?” in experiment settings then this should get around the problem by skipping this check, but I’ll also fix it so that the rounded value of frame rate has to be at least 1 for this calculation.

I don’t have such option in the experiment setting, is that a new feature in the newer version? I’m running on v2023.2.1

1 Like

Ah my mistake, I thought that was added earlier - it’ll be in the upcoming release (2024.1.0) but as will a proper fix for this bug

Is there a quick fix for now?

Any fix for this yet?
After uninstalling 2022.2.4 and installing Standalone 2023.2.3 I get the same problem on both of my HP laptops. I eventually had to revert back to Standalone 2022.2.4.

1 Like

How can I disable this auto-detection of the screen rate? I have to use the experiment without web access, as I need to run it in a hospital. It is possible to write a code snippet to set expInfo[‘framerate’] before the experiment starts, but this, unlike what chatGTP claims, does not stop this attempt at on-line autodetection (and crash).

It seems to me that this option disappeared in the latest version! Not OK …

Are you talking about the frame rate detection message (frame rate detection is not new) or checking for an online connection when PsychoPy starts up?

2024.1.4 is the latest release at time of writing so you should now be able to switch frame rate testing off in the Experiment Settings and manually specify a frame rate - at the bottom of the Screen tab:

Keep in mind that the “Frame rate” control is hidden when “Measure frame rate?” is ticked as the frame rate specified there wouldn’t be used (PsychoPy will use the measured frame rate) - that may be why it seemed to disappear?

Is there any way to manually set the framerate using the coder? My experiment is also frozen when using an external HDMI switch box. I don’t have the option to change anything about the hardware setup or update the PC or any of the equipment.

If you use checkTiming=False when you create the window then it won’t run the frame rate check