403 Forbidden when trying to run an experiment that worked fine up until yesterday

URL of experiment: https://run.pavlovia.org/RenataKoch/3-in-1-experiment/html

Description of the problem: I have been collecting data for a month with this experiment, it worked fine and never gave any such errors. Yesterday night around 9PM GMT a participant reported to me that they got error “403 Forbidden” when they tried to run the experiment. However, I have not touched the experiment files since a few weeks ago, and during those weeks have collected a couple of dozen of responses. But today I get the 403 error all the time when I try to run or pilot the experiment.

I have tried some things with no success:

  1. cleaned the cache and did a hard reload (also tried on another browser and incognito mode);
  2. changed the experiment status to Inactive and then reverted to Active;
  3. updated the number of assigned credits;
  4. logged out and in again to Pavlovia;
  5. created a copy of the experiment by downloading the experiment files from gitlab, opening the .psyexp file in the Builder and pushing the experiment to a new project on Pavlovia;
  6. in this new copy of experiment, I copied the .js and .html files to the folder html/resources.

I’m out of ideas and would appreciate any suggestions.
I have also just seen the note about the unexpected outage last night (potentially around the time when my participant encountered the 403 error). Could my experiment still be affected by that?


I think that you have probably just updated your experiment to 2021 and need to recreate it without the html folder.

Thank you very much, it helped.
I still don’t know how the update to 2021 could have taken place without me touching the experiment in either builder or gitlab, but the solution worked and that’s brilliant!