psychopy.org | Reference | Downloads | Github

403 Forbidden HELP

URL of experiment:
https://run.pavlovia.org/Zotova/flanker-task
Description of the problem:
Hello! I don’t understand why I can’t Pilot or Run my experiment, I get the 403 Forbidden page.In Psychopy I run it, it’s OK. Already Updated Psychopy 2021.1.2.

Have you set it to Running?

Does the experiment page show a Platform Version?

Yes, I runned it in the Psychopy, it was OK, but on a Platform version I can’t pilot nor run it

I’m not sure you understood what I meant.

Please could you show a screenshot of your experiment page on Pavlovia?

Yes, sure:)

While changing from “Running mode” to “Pilot mode”, this error appeared. Maybe you know what does it mean?

Platform version 0 means I think that you haven’t managed to sync your experiment with valid code

1 Like

Could you please help whether should I go to the Programm or to the Gitlab first?

You should sync from Builder. What happens when you try?

There appears a line about committing changes (I press Cancel), then this error (screenshot)

What is the message you are pressing cancel to? It sounds like “Do you want to sync?” in which case Cancel would explain why you don’t yet have a testable experiment online.

No, I press Cync, than appears this question about changes I make in these files (but I don’t make any changes), and than nothing happens. I’ll better show you a screenshot again to better understand.

Also it gives me this error:

RuntimeError: wrapped C/C++ object of type StdOutText has been deleted

I have no idea what happens:(

One file deleted is a change though I recommend you try making a minor change to the Builder. Is the experiment set to a pre 2020 version in experiment settings?

1 Like

Maybe you need to reinstall PsychoPy.

I made the experiment in the 2020 version, but I installed today the latest version 2021.1.2.
I guess there can be the point of my problem in these changes of versions.

I’d recommend that you either go forward to 2021.1.3 or back to 2020.2.10.

Thank you very much!!! I’ll let you know, I hope it’ll help