When converting a length from stimulus unit to pixel units unable to deal with unit: cm

URL of experiment: Pavlovia

Description of the problem: I have carefully removed all reference to cm in both images and text (in advanced); am using height units in experimental settings, and from exp settings in actual stimuli - but am still getting this error when I try and run it online. I am using 2020.2.4 and Chrome. help!

Are you running the latest version of your code? Use Ctrl-Shift-R or an incognito tab to run the latest version.

You might also find my screenscale routine useful if you want cm online.

Morys-Carter, W. L. (2021, May 18). ScreenScale [Computer software]. Pavlovia. https://doi.org/10.17605/OSF.IO/8FHQK

Hello, thanks for your reply! After making the changes I described I re-synced the project and re-exported the html before I ran it - is that what you mean? and I don’t need to use cm, I am fine with height for the device versatility. (I don’t follow the rest of your reply, sorry; control shift R at what point? I am in pilot mode on Pavlovia…)

!!! I tried again this morning, just to be sure (added some innocuous text to an instruction, and yet again reexported html and resynced) and it worked. !! Weird, but I’ll take it. Thanks anyway!

I have export html on sync (the default in Experiment Settings / Online) so I never export html separately.

Ctrl-Shift-R is the shortcut I use in the Browser when testing an experiment I’ve just edited.

Ah ok - thanks! But I have a different problem now! I am using a different machine running big sur, and just downloaded 2020.2.4 and it won’t run - giving this error:

ImportError: Can’t find framework /System/Library/Frameworks/OpenGL.framework.

I don’t suppose you have any idea? or I can repost… (I was using a desktop with Catalina before)… a bit of googling suggests this may require a python update or something, and that it’s still a bug with big sur…)

I wouldn’t personally recommend 2020.2.4. Try 2020.2.10 if you want to stick to an older version. I think this bug was fixed in 2020.2.8.

Thanks! actually may have been related to this machine not having an Intel chip… but sorted now. Thankyou!!

1 Like