WARNING: pytables package not found. ioHub functionality will be disabled

OS: Windows 10
PsychoPy version: v2022.2.4

I am programming a stroop task where an individual has to press the key that is congruent to the colour of the letter. When I am trying to run the experiment a black screen appears and the experiment ends. The errors displayed are:

WARNING: pytables package not found. ioHub functionality will be disabled.
Traceback (most recent call last):
17.2933 WARNING Trying to use a framebuffer object but GL_EXT_framebuffer_object is not supported. Disabled
File “C:\Users\Lenovo\Desktop\Psychopy\Strooptest_lastrun.py”, line 193, in
win.flip()
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\visual\window.py”, line 1082, in flip
thisStim.draw()
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\visual\text.py”, line 714, in draw
GL.glUseProgram(self.win._progSignedTexFont)
AttributeError: ‘Window’ object has no attribute ‘_progSignedTexFont’
################# Experiment ended with exit code 1 [pid:4712] #################

I have checked the code multiple times and there is no error there. I have downloaded and installed PsychoPy again, but the error keeps appearing. Can anyone please help me with this?

I have the same problem, has there been a solution yet?

No solution.

While not exactly the same issue, I was having the same error with pytables and ioHub this morning (for an eyetracker experiment on a Windows 10 machine in my case), and solved it by installing the 2017 Microsoft Visual C++ Redistributables. This fixed my problem - hope it helps you.

Just curious if anyone (@Julsten @Sanjita or others) has been able to solve the problem with this C++ Redistributables approach, or through another route. I’m currently unable to try it but am still having this pytables issue.

Hi,
we were able to solve the problem in our workgroup by re-installing windows on the machine. This might have also installed the C++ Redistributables mentioned by @tyhayeswbs, but I am not sure about that. Anyway, with this new windows version everything works as intended :slight_smile:

It did not help me, hope it helps you.

Thanks all. I have found two machines here with the same version of 1) Psychopy (2022.2.4) 2) Microsoft Visual C++ Redistributables (2010 KB2565063 10.0.40219) and 3) Windows (Windows 10). I get errors on import numexpr on one but not the other. Maybe there is some Windows subversion thing or hardware interaction going on.

I really thought the same version of the C++ Redistributables would produce the same result since the few other threads online (e.g. here and here) as well as @tyhayeswbs point to that as a potential issue. Will post again as soon as I’m able to try updating one of the machines.

I was able to get the redistributables updated on two computers and this did fix the issue with numexpr/pytables.

I should note that this update did not get reflected in the version of the redistributables appearing in the Installed Updates list (accessible via Control Panel) so I guess the info there is unreliable. This may be why the problem did/did not occur on machines with the same apparent version of the redistributables.

Thanks again @tyhayeswbs for the suggestion.

Reinstalling Psychopy did not work for me but everything started working smoothly after running conda install pytables in my conda environment