psychopy.org | Reference | Downloads | Github

Using audio files online, error: unknown resource


#21

Great, but when I view the trial handler in the online debugger, the files in the ‘stim’ variable only hold reference to a the file number at the beginning of the file, that’s why I mentioned this:

image

I have reported the error on GitHub and made an example, so you can always edit your experiment now. I would use a new Excel file, and remove numbers from the start of my file names.


#22

Excellent. I will give it a try and report back. Would you mind posting a link to the github issue for future reference? I took a quick look but didn’t see it.


#23

No problem, here is the link - https://github.com/psychopy/psychojs/issues/30


#24

Just to confirm, the sound files are now working properly. Renaming the files did the trick. Thank you for your help.


#25

@dvbridges would you mind explaining how one can access the online debugger? I am now creating a similar experiment to the one described above and I am getting the following error:

Unfortunately we encountered an error:

- when getting the value of resource: b
- unknown resource

Try to run the experiment again. If the error persists, contact the experimenter.

#26

@jvcasillas, you press F12 to open developer tools. Then, you find your script in the sources tab and add breakpoints where you want to pause the script and check what is going on. Move to the console tab for evaluating variables etc.


#27

Hi, I have the same problem as above, only with my visual stimuli. I have made sure that I have both the .png and the forward-slash. However, I don’t quite understand how to check if empty trials are created in the trial hanlder, and how that is caused by my conditions file formatting. I’ve added the screenshot and a link to my experiment:


Links:
Gitlab link
Experiment luanch link

Thanks a lot for all your help!


#28

Hi @Nessimon, I am not able to view your project repo, probably because it is private. Could you expain the folder structure within the Resources folder? The ImageStim that you are trying to load needs to access, for example Images/introB.png, so you will need an Images folder within the Resources folder for this to work.


#29

Thanks, then I had not set it up correctly, I simply had a folder called ‘Images’. However, I tried to add a folder called ‘Resources’ and then add the ‘Images’ folder there. It did not resolve it, the exact same error message persisted. I’ve opened up my repository now:
Experiment
Gitlab


#30

@Nessimon, when you do your project sync, or html export, a resources folder should be created for you in the html folder. That is where you want your images, so your folder structure should be html > resources > Images.