Unwanted sound at the end of a trial

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): v2021.1.3
Standard Standalone? (y/n) If not then what?: no
What are you trying to achieve?:
I’m working on an EEG experiment in which, during the visual word-by-word presentation of a sentence, a pure tone (50 ms duration) is presented at different time points in the trial. The frequency of the pure tone is either 550Hz or 1400Hz.
The experiment is to be run in a Windows10 laptop that is connected to a CRT monitor.

What did you try to make it work?:
The script is set to present visual/auditory stimuli and send triggers with a 60Hz refresh rate (RR). All works fine in terms of stimuli presentation and timing.

What specifically went wrong when you tried that?:
However, randomly, an unwanted sound (like a click) appears at the end of the trial. The unwanted sound disappears if the RR is set to 40 Hz, but unfortunately this is not an option because this RR is not supported by the screen the laptop is connected to for stimuli presentation.
The unwanted sound also does not occur in a mac machine (but this again is not an option because it does not have a parallel port).
The script does not output any error.
Any cue whether/how this problem can be solved?

Hi There,

How are you presenting your sounds? is it using PsychoPys inbuilt tone generator or using a wav file?


Hi Becca,

Thanks a lot for your quick reply! I forgot to mention that in the topic, I use wav files.
Could generate tones with the inbuilt generator fix the issue?

Arrivato mar, apr 12, 2022 alle 20:54, Rebecca Hirst via PsychoPy <notifications@psychopy.discoursemail.com> ha scritto:

I would maybe give it a go - the reason I ask is because it sounds like for some reason the audio file is being clipped! If that is the issue another approach might be to add ramping or silence to either end of your audio clip


Adding ramping and silence to the wav files were the first things I tried, but it did not work.

I did not try generating the tone with the inbuilt generator, though, so I’ll give it a try. I’ll let you know!
Thanks a lot,

1 Like

Hi Becca,
I generated the tones with the inbuilt generator and it worked just fine, thanks!