psychopy.org | Reference | Downloads | Github

Unknown resource - experiment trying to find an old video which is no longer used

Description of the problem: When my experiment tried to run a routine containing the movie component in Pavlovia I am getting the ‘Unknown resource’ error. I know there are heaps of these threads all over the discourse but I couldn’t find any fitting my issue.

The issue is that the experiment is saying it can’t find ‘video&audio/afford_touch_edited.mp4’. Well, I don’t want it to find this video. I recently changed the videos in this folder so they are all ‘video&audio/afford_H&P_edited.mp4’ instead. All the videos have been renamed according to this pattern and I have updated all the file paths in the Excel file.

However, despite PsychoPy saying I am successfully syncing to Pavlovia, something is obviously going wrong because Pavlovia is still looking for the old file, despite this not being referenced anywhere that I can see. I have checked the Excel file that is with my experiment in GitLab and that too has the correct video path names. I can’t figure out why Pavlovia is still looking for an old file - ideas hugely appreciated.

Okay, so I’ve found a way around this, which was to delete the generated JS, gitignore and index files in the experiment folder and then create a new project on Pavlovia with a new name. For some reason creating a new project with a new name meant everything synced correctly and the videos were able to play.

Still no idea why this issue occurred in the first place.

I know you’ve solved it but this is the kind of case where Ctrl-Shift-R should work (or using an incognito tab).

Hi @wakecarter, thanks so much for the suggestions. Clearing the cache didn’t work, but using an incognito tab did. Does this mean my participants would need to use an incognito tab, or would it work for them without this?

Update: I have got this issue with more than one experiment and trying the incognito tab method with a different one didn’t actually work! I’m also getting the error in multiple browsers (Chrome and Edge).

The incognito tab helps to ensure you are using the latest code rather than a local cache. This isn’t an issue for participants unless they have previously helped with piloting.

If you are having an issue where this doesn’t work then maybe it’s different. Check the commits on Gitlab to see if your latest code has been uploaded. If you are using the old html folder method then resources were duplicated so changes may need to be done in both locations.