Unable to upload experiment online, permission problem

Hi all,

I am trying to upload my experiment on Pavlovia. It is an easy experiment and it runs locally.

When I press on the javascript button, It gives me this error:

Traceback (most recent call last):
File “C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py”, line 804, in fileExport
File “C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 71, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 245, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 217, in makeTarget
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\experiment_experiment.py”, line 286, in writeScript
self_copy.settings.writeInitCodeJS(script, self_copy.psychopyVersion,
File "C:\Users\Tartaro\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\experiment\components\settings_init
.py", line 857, in writeInitCodeJS
with open(os.path.join(folder, “index.html”), ‘wb’) as html:
PermissionError: [Errno 13] Permission denied: ‘C:\Users\Tartaro\Desktop\Sem3\Scripts\Validation\Emocio\index.html’

When I try to upload it on Pavlovian, it gives me error 404.

I tried to run Psychopy as administrator but nothing changed. The folder is on the desktop. I saw it does not create the javascript in the folder.

Any idea how to fix this?


Can you take a screenshot of your online tab?


Hi, I’m also really struggling with this issue. I tried to upload before, but got an “unknown resource error”. I had already included my images and audio files in “Additional resources” in expt settings. So, based on other posts, I changed my file names from " / " to " \ ", but when I tried to sync again, I got this error:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py”, line 1369, in onPavloviaSync
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py”, line 808, in fileExport
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app_psychopyApp.py”, line 729, in showCoder
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\coder\coder.py”, line 2734, in setOutputWindow
File “C:\Program Files\PsychoPy\lib\site-packages\wx\lib\agw\aui\framemanager.py”, line 6388, in Update
File “C:\Program Files\PsychoPy\lib\site-packages\wx\lib\agw\aui\framemanager.py”, line 6582, in DoUpdate
File “C:\Program Files\PsychoPy\lib\site-packages\wx\lib\agw\aui\framemanager.py”, line 8773, in Repaint
client_dc = wx.BufferedDC(wx.ClientDC(self._frame), wx.Size(w, h))
wx._core.wxAssertionError: C++ assertion “m_buffer && m_buffer->IsOk()” failed at …..\src\common\dcbufcmn.cpp(134) in wxBufferedDC::UnMask(): invalid backing store

I have tried this with and without html written in the output path and tried deleting the project online and re-uploading with a new html folder. Have also deleted git hidden folder. I’m totally stuck, any help would be very much appreciated. :pray:

Try closing the coder window and retrying.