psychopy.org | Reference | Downloads | Github

PsychoPy won't start (ver 1.84.2)

Hi there,

I hope this is not a previously asked question, but I did not find an answer in previous posts on this.

We run psychopy on our lab computer, and overnight it decided not to start up again.
When clicking the Psychopy icon, Psychopy is not mentionned in Task Manager.
We use PsychoPy 1.84.2 and Python2.7.
After re-installing the same PsychoPy version, the problem persists.

This is the error we get:

Traceback (most recent call last):
File
“C:/Users/admin/Desktop/experiments/grid_stim_Olivia/drawing_expt.py”,
line 1, in
import psychopy
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy_init_.py”,
line 42, in
from psychopy.preferences import prefs
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences_init_.py”,
line 8, in
from . import preferences as prefsLib
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”,
line 232, in
prefs = Preferences()
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”,
line 43, in init
self.loadAll()
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”,
line 136, in loadAll
self.appDataCfg = self.loadAppData()
File
“C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”,
line 189, in loadAppData
encoding=‘UTF8’, configspec=appDataSpec)
File “C:\PsychoPy2\lib\site-packages\configobj.py”, line 1229, in
init
self._load(infile, configspec)
File “C:\PsychoPy2\lib\site-packages\configobj.py”, line 1318, in _load
raise error
configobj.ParseError: Invalid line (u’ “”’) (matched as neither section
nor keyword) at line 135.

Any idea what is going wrong here?

Thank you a lot.

Hi @Koen_Rummens, there seems to be some problem loading your appData, and perhaps they need to be reset. Follow these guidelines to delete your prefs and start again. Note, your file location may be different to the one in the link. In Windows 10, my files are found at C:\Users\MY_USERNAME_\AppData\Roaming and the “AppData” directory was actually hidden, so needs you may need to set your folder options in Windows to show hidden files.

http://www.psychopy.org/troubleshooting.html#cleaning-preferences-and-app-data

1 Like

thank you, @dvbridges. that solved the problem.