psychopy.org | Reference | Downloads | Github

Unable to create link to PsychoJS library folder

Description of the problem: I synced my experiment with an online project, and activated it before trying to pilot. It won’t generate the pilot URL, and has the error as below:

unable to create link to PsychoJS library folder: [Errno 17] File exists: ‘/var/www/pavlovia.org/lib’ -> '/var/www/pavlovia.org/run/tlan/t4/html/lib’

Please help me with troubleshooting it. Thank you very much!

I think you have a lib folder in your html? Remove it as it’s clashing with the psychojs lib on the server :slight_smile:

1 Like

@jon Thank you, Jon. It’s piloting properly now…

@jon On another note, the .js files in the html folder don’t seem to be updated on Pavlovia upon syncing. They are updated locally on my PC though.

Any idea why?
Thanks.

Never mind, I figured out that I made a mistake when syncing.

Could it be that the “Run PsychoJS task in local debug mode” option in the runner creates the html/lib folder, which then causes those problems?

@LukasPsy, yes if the html/lib folder generated from the local debug mode is synced with the Pavlovia repository, this issue will occur. There should be an entry in the .gitignore file to prevent this from happening, but this will fail if the .gitignore is deleted or modified in some way. It will be interesting to know how the issue has occurred in this instance.

2 Likes

Thank you for your answer :slight_smile:
You are right, I had a custom .gitignore file.

For future reference: If you want to restore your gitignore file to the default or if you want to add the critical part about the lib folder to your existing gitignore file, I think this is the file to copy from: https://github.com/psychopy/psychopy/blob/master/psychopy/projects/gitignore.py