psychopy.org | Reference | Downloads | Github

TypeError: Can't represent a Param of type file: Strange issue with experiment both on desktop PsychoPy and Pavlovia

OS (e.g. Win10): Mac OS
PsychoPy version (e.g. 1.84.x): I have tried multiple versions, including the latest version.
Standard Standalone? (y/n) If not then what?: Yes
What are you trying to achieve?: I am trying to get my study up online. Some subjects will be run on Pavlovia and others will be run on a desktop, so I need both to be working. I’m having two simultaneous issues that I think may be related

1.) I can upload the experiment to Pavlovia, and it runs, but it will not sync any of my changes that I make in builder. I have tried deleting all other experiments to make sure it’s not accidentally pushing to the wrong experiment. I’ve tried pushing it to new experiments. I’ve checked the code on GitLab and it appears to be updating, and I see my parameters in the .psyexp code, but they still do not show up in the online experiment.

2.) When I try to run the experiment on my Desktop, I get weird formatting errors and strange characters showing up on the screen. This error appears: KeyError: 'gammaErrorPolicy' and sometimes, this error appears: TypeError: Can't represent a Param of type file. I’ve tried to run other Builder experiments that I have made in the past, and none of them are having these issues.

The only other thing I can think of is that I had this .psyexp file shared with me from a collaborator. We tried sharing the file via Slack, DropBox, and email. I’m not sure if some weird encryption thing is going on.

I am attaching all the experiment materials in the hopes that someone might be able to help me discover what issue I am having.

dummy.csv (2.0 KB) eight.csv (67 Bytes) eleven.csv (79 Bytes) five.csv (58 Bytes) FlankerDissertationBlock.csv (150 Bytes) four.csv (55 Bytes) nine.csv (70 Bytes) processing_only_2 - Copy.csv (438 Bytes) processing_only_2.csv (438 Bytes) processing_only.csv (510 Bytes) PSWQ.csv (789 Bytes) seven.csv (64 Bytes) six.csv (61 Bytes) STAIQ.csv (109 Bytes) SternBergStim_prac1.csv (26 Bytes) SternBergStim.csv (47 Bytes) SternBergStimReal_2.csv (104 Bytes) SternBergStimReal.csv (104 Bytes) Study1_lastrun.py (434.7 KB) Study1.psyexp (568.4 KB) Study1.py (501.1 KB) ten.csv (76 Bytes) three.csv (52 Bytes) to_csvs.py (362 Bytes) twelve.csv (82 Bytes)

I suspect that your first problem is due to your second, and that that issue is because you have a file name without an extension or similar somewhere.

When you say file name without an extension- do you mean that I am referencing a spreadsheet or something that doesn’t exist in the folder?

I am not clear what an extension is, in this circumstance, do you mind clarifying? Thanks for your help.

.csv and .png are file extensions

Are you using two monitors?

I am not using two monitors. I have checked and all the correct .csv files are currently in the directory, and I am not referencing any .png files.

I tried running in 3.2.4 and this also did not work. Still getting the strange symbols.

Where did you get window.shuffle = shuffle from?

If you are trying to run this online then you really ought to be using at least 2020.1.3 and take a look at my crib sheet.