Type Error: readPixel web browser issue

URL of experiment: any experiment

Description of the problem: None of the online experiments seem to work on my web browser (chrome version 72.0.3626.81) on surface pro 3. However, seems to work on chrome on my android. Here is a screenshot of the error I get

I have the same problem. Does anyone have a fix for this?


I am also experiencing the same Issue - however, from what I understand from my participants, it does not happen on all machines. Unfortunately, I am currently unable to figure-out the source of the problem.

HI @AndreiCostea, I had this problem on my home computer, and I think it may have been related to my NVidia graphics driver running on Linux, but cannot check until later if it also fails on Windows ( see also https://bugs.chromium.org/p/chromium/issues/detail?id=817400). There is a test that can be run to make sure ReadPixels is working here. Without knowing a bit more about your users computer e.g., graphics drivers, OS, and browser being used, I cannot be much more useful. However, I will create a GitHub issue later with details of my setup that recreates this error.

Hi @AndreiCostea, @LittleMary, @haaleemur,

Did any of you manage to find a workaround for this problem? I am having the same issue on Chrome running on Windows 10 (but the problem does not arise when I try running the task on a friend’s Mac, in either safari or chrome).

Does anybody know if there’s a definite fix for this at all? I am collecting my 5th experiment on Pavlovia since last July, and the error still pops up for a number of people.

Thank you in advance!!

I’m also having the same issue but only for Chrome.


As my experiment runs perfectly fine on Opera.


@CDawes what version of PsychoPy/PsychoJS? We’ve done a lot of work on compatibility in the last 6 months (actually more improvements coming in PsychoPy3.3) so maybe you output your study from an old version?

Without seeing a URL to check studies we can’t help very much

Hi Jon,

I’m using 3.2.4 and the URL is https://run.pavlovia.org/CDawes/testpsych/html/

My units are norm in experiment settings and also on every component :slight_smile:

Thanks, actually @apitiot apparently has a fix for this in v3.3 but might be able to back-port that fix to earlier versions too. I’ll keep you posted and then we can see if you can test if it fixed it for your study

Good afternoon,

I have just back-ported the 3.3 fix. I believe the experiments should now run fine, but do let me know if that is not the case!


Hi Both,

Thanks for looking into this. My experiment still doesn’t seem to run on Chrome due to Read Pixels error, it is stuck on the initialising screen on Edge with no errors, but is fine on Opera.

I also get the same errors on my second experiment: https://run.pavlovia.org/CDawes/prl/html/

I’ve also tried running only my first routine presenting only an image and that by itself also doesn’t seem to run.

All the best,


Hello again,

Have you tried to empty your browser cache? I don’t quite see how it would not work at this stage, considering that the call to readPixels is protected by a typeof test.


1 Like

That did it! Worked straight away!

Thank you both


1 Like


1 Like

Hi David: I know this is an old post, but I am still having the read pixel error for my study. And I am trying to think of a way to inform the participant if their browser will work as soon as they open the study, so if it doesn’t work, they can return the study with minimum time wasted. So I have messaged one participant who had the issue with the read pixel test link that you posted here and surprisingly his browser passed everything. And the Chrome Version is 80.0.3987.106 (Official Build) (64-bit), which is pretty new. Now I am confused, he shouldn’t be having problems if his browser passed the test, right? Any ideas?

Thanks in advance.

Just adding more information here. Another participant replied who experienced the same issue. In his case, the test indeed failed on a windows machine with chrome Version 80.0.3987.122 (Official Build) (64-bit).