Troubles pushing from PsychoPy to Pavlovia v2022.2.5

Hello experts!

I hope that you are well

My intention is: I want to pilot my study online and give participants an URL to run the study in their browser.

The problem is: when I try to push the experiment that I have created locally on PsychoPy with the ‘Run the study online’ button, it has given me on Safari a blank page, a 404 page, a 403 page, or the problem that I am currently experiencing that I explain below.

Detailed explanation:
I press on the ‘Run the study online’ button and I get this message: “Project root folder is not yet specified, specify project root now?” even though I did specify it before.

Then the ‘Syncing project window’ opens and it shows:
Sync failed - could not find project with id AlejandraXVY/acceptability

‘Acceptability’ was a previous project that I tried to push to Pavlovia before (getting only blank, 404 and 403 error pages) and that I finally deleted and created the 3 new ones below.

Then it shows the ‘Psychopy3 error’ window with this text:

Traceback (most recent call last):
File “/Applications/”, line 594, in getitem
KeyError: ‘path_with_namespace’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/Applications/”, line 1393, in onPavloviaRun
File “/Applications/”, line 596, in getitem
AttributeError: ‘NoneType’ object has no attribute ‘attributes’

What I I can see in my PsychoPy runner is:

284.4940 EXP Imported /Users/alejandramaroto/Documents/PsychoPy Ale/AJTlist2/AJTList2.xlsx as conditions, 40 conditions, 6 params
285.7283 ERROR unexpected indent (, line 1)

I haven’t done any coding for these experiments, I have only built them using the interface.

My Psychopy version is (v2022.2.5)
My ID on Pavlovia is: AlejandraXvy
My experiment names are:
AJTlist1 Gitlab ID: #330707
My laptop is MacOS 13.4.1 (but I also experienced the problems before this update)

I have never managed to push any experiment to Pavlovia successfully, could you please guide me towards how I could possibly fix the problem?

I think all the files for the experiments are uploaded to GitLab, I added an SSH key and I changed the status to ‘Piloting’ there but that hasn’t made any difference. I would appreciate any insights you may have.

These will be my first experiments and my first time using PsychoPy and Pavlovia.

Thank you for your time and help!

Kind regards,

Hi There,

A couple of things to check that you may or may not have tried:

  • when you click the "compile to javascript: icon :compile_js: is a javascript file actually compiled? 404 errors can sometimes occur when there is no JS file.
  • If you use the keyboard shortcut cmd >shift > period whilst in your experiment folder location, is there a hidden .git file? (this is what indicates the project is successfully linked to a pavlovia/gitlab repository).
  • Have you tried updating your PsychoPy version?


Dear Becca:

Thank you so much for your help!

I updated my version to 2023.2.2 and I was still getting the “404 Not Found nginx” error.

When I clicked on the compile to Javascript button 2 files appeared: AJTlist1-legacy-browsers.js and AJTlist1.js

When I ‘cmd >shift > period’ I do see the git folder and other hidden files: .git, .gitignore .Rhistory

But still, when I click Run in Pavlovia it still doesn’t work and I get:

‘Message: The file doesn’t belong to any existing file’

Then I click on create a project with the same name and same location and I get:

‘Message: Project AlejandraXvy/AJTlist1 already exists, please choose another name.’

Then when I cancel I get:

‘PsychoPy3 Error’ with these details:

Traceback (most recent call last):
File “/Applications/”, line 601, in getitem
KeyError: ‘path_with_namespace’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/Applications/”, line 1466, in onPavloviaRun
File “/Applications/”, line 603, in getitem
AttributeError: ‘NoneType’ object has no attribute ‘attributes’

My Pavlovia link:
My gitlab link: Sign in · GitLab

Is there anything I can do so that it works?

Thank you for your time!