psychopy.org | Reference | Downloads | Github

The first sound file in each block get clipped

URL of experiment: Url: https://pavlovia.org/run/gshejaeya/ex_session2/html/
and also in this experiment Url: https://pavlovia.org/run/gshejaeya/ex_session1/html/

Description of the problem:
I have an auditory perception study with three blocks that has audio stimuli that last for about 1 sec for each. The issue is that some participants are complaining that the first audio file in each block is clipped. Only the first stimulus. However, this issue does not happen every time you run the experiment. I tried it and it worked fine.
I had this problem when I first built the experiment but I solved it by adding a loop with a silence audio file that lasts for 1.5 seconds. But I don’t know why the problem is happening again.
How can I solve it? @Becca @sotiri
Thank you,
Ghadad

Hello gshejaeya

well this might be a file-loading problem. Did you set audio to a fixed duration? The duration time you specify in PsychoPy does not take loading into account. You might want to add a static-component and load your audio-file during that period.

Best wishes Jens

I tried that but it didn’t solve the problem! :pensive:

The same issue also applies to this experiment
Url: https://pavlovia.org/run/gshejaeya/ex_session3/html/

Dear gshejaeya,

if your are interested that someone takes a look at your program you need to give access (making it public and posting the link to it here) to the repository, not to the running version of your experiment.

Best wishes Jens

I thought that I made it public. How do I do that for the repository?

Hi There,

You can make a repository public as follows:

  1. from your experiment page click “view code”
  2. on the left toolbar select the settings icon
  3. general
  4. permissions > change to public and save

Becca :slight_smile:

Yea I know that one and my experiments are all public. I thought that there is additional step I should do to let others see my codes.
Thank you

Hi @gshejaeya, no problem, on it, thanks for flagging, x

Hi @gshejaeya, sorry, because your project is rather extensive, could you please elaborate in terms of which routine types showed up problematic? Is it the ones where the duration is set on demand such as sound_3 or e.g., trials in screening_loop2 where the sounds are allowed to play in full? Thanks, x

At the beginning of all my experiments there are: calibration_noise, screening_test, screening_test2. The audio files in these routines have never been clipped.
The routines that have name like sound, sound_3, sound_9 …etc are loops I added with a silence sound file in each of them. When I added them, the first audio files of the following routines were not clipped. But I am not sure if that works always.
The problem occurs usually in the first audio file of the routines: Practice, Pretest, Block 1, and Block 2 where the first audio may be clipped.