psychopy.org | Reference | Downloads | Github

Sound ends\stops before it should -- Audio is cut short in Builder and Online

Hello all,

I’m running an experiment using audio stimuli. Each audio has different duration. For some reason, Psychopy is presenting only parts of the sounds. For example, if the audio presents the sentence " The boy is eating a cake", the audio in the experiment will be :" The boy is eating ".

I’m attaching her a link to the experiment in Pavlovia. I would appreciate your help!

Thank you!

I just figured this out, I’ve been having this problem since forever. Here is what I did :
1- In the main exp setting make sure you choose pygame as audio libary.


2- do not put a duration for the onset ( leave it empty)
3- make sure you press the “hamming window” option in the settings of the audio
4- you can try to add a code component at the end of the routine, and write “NameOfSoundStimuli.stop()” in the End Routine section of the code.

1 Like

I’ve just been looking into this and I can replicate the issue but only in our sounddevice audio engine. I would strongly recommend the PTB backend for the best audio timing.

If anyone finds it’s a problem in the PTB backend then please post a Minimal Working Example of the issue with info about your platform so we can try and debug there.

Indeed, I have had some comments about sound being cut of for some experiments, even online, using the sounddevice engine. However, changing to ptb for me still results in incorrect pitch/speed of the audio locally on a MacOS.