textInput demo does not work once synced with Pavlovia

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 2020.2.4
Standard Standalone? (y/n) If not then what?: y
What are you trying to achieve?:

I have been trying to use the code snipet from the textInput demo in an experiment so that the participant can type in a sentence.

What did you try to make it work?:

I created a an experiment in Psychopy that seems to work perfectly. If I sync it with Pavlovia, Psychopy reports a successful sync in the Runner - e.g. “succesful sync at 16:12:16, too 3.564s”.

However, when I try to run it in Pavlovia it gets stuck immediately with “Initializing the experiment…” on the screen. I have since worked backwards and forwards trying to identify what component does not work, and it seems to be the textInput code.

As a sanity check I eventually downloaded the original textInput project and tried to sync it myself. Just as with my larger project, it works perfectly with Psychopy, but stops with the “initializing” message if run from Pavlovia. The version that was already on Pavlovia does seems to work, so I presume that the same code somehow will not sync properly any more?

Did you inititalize your textinput with an empty string? This a bug, see here. An update is on the way if you don’t persue the solution mentioned in this thread.

Cheers Jens

Hi Jens, thanks for taking a look.
I believe it is initialised. The Begin Routine reads

modify = False
text.text = ‘’


text.text =’’ is the problem. Check your *.hmtl. I bet this line reads text: /* */, which is a comment in JavaScript. Try setting text.text = “dummy” and see whether the experiment initialises.

Cheers Jens

Thanks for chasing up. I did look at the thread that you mentioned, but didn’t really grasp the implication.

Unfortunately, putting ‘dummy’ in has no effect on the initialisation. It does affect the program in Pavlovia, though, as the text is preloaded with ‘dummy’ which appears on the screen.