psychopy.org | Reference | Downloads | Github

Running study with Pavlovia works OK, but unable to save data (Lab.js based study)

pavlovia

#1

The study link is below (set to be publicly accessible):

I made a test study with Lab.js and exported it with the “generic web host” option, which yields a folder with a “index.html”, “backend.php”, “style.css” and some other files. Then I installed Git, link it to Pavlovia and pushed these files. Next I activated the study and tried to run it, which only resulted in a “403 forbidden” page. However, I solved this by deleting the “/html/” string in the study link ( https://pavlovia.org/run/HUSKYSPEAKS/IT_Perception/html/). I also try to move everything in the actual study into a subfolder named “html” but it only led to failing to activate.

After solving this issue, I did some test runs myself, but found that the data file was not stored in “data” folder. But when I tested the study in Lab.js environment and my local computer, data was saved normally. I suspected there is some kind of permission denial happening in the “data” folder and deleted the content from the hidden “.htaccess” file in that folder. But this did not work.

I searched online but there was almost no materials regarding Lab.js and Pavlovia both, yet Pavlovia is supposed to support lab.js studies as far as my understanding of this platform and also what I learned from a youtube video titled “Launch of PsychoPy3 and Pavlovia.org” by one of the founder himself.

So to sum up: 1. why the default study link does not work? 2. how to make writing data possible with this lab.js study? Could someone please help me out a bit on this issue ?