psychopy.org | Reference | Downloads | Github

Running on new computer

Hi,

Following my trials to migrate to version 1.84, I decided to go back to 1.82.01 which is working fine on my other computer.
I thought that code that runs well on one computer will run also on a new computer.
I have an experiment with a Cedrus box and parallel ports.
On the new computer I get the error:

send_trigger_start_sequence = parallel.ParallelPort(adress=‘0xE)50’)
AttributeError: ‘moidule’ object has no attribute ‘ParallelPort’

The code is:

from psychopy import core, parallel, visual
port = parallel.setPortAddress(0xB050)#address for parallel port on our PC

s=Server(sr=44100,duplex=0)

send_trigger_start_sequence = parallel.ParallelPort(address=‘0xE050’)

When I do change the command to setPortAddress, then the experiment start running, but at the 2nd time I am supposed to press on the Cedrus box - it never accepts my response, and stops working.

Again, the exact same code was used fine on a different computer with the same version. I even copied all the "site-packages’ directory from the “old working” computer to the new one and it didn’t help

I tried to generate a new PsychoPy new experiment where I just added a p_port object via the GUI and ran it.
I also got the error. Doesn’t the Builder supposed to “translate” the GUI component to code which is understood by PsychoPy ?

Any suggestions ?

Noa

It sounds like the issue specifically has to do with the parallel port, so I would make sure that’s working before doing anything else.

I described a solution to getting my parallel port working here, which may get you started, but a search on this forum should give you other ideas as well.

Updates:

I managed to check the parallel port. It works fine (I downloaded a program that I can change pin values in the parallel port and I see it when connecting oscilloscope to the parallel port).

Moreover, I have an exact same computer with the same ports and port addresses, and in the second computer I did succeed to send values to the parallel port via PsychoPy 1.84.02.

So I went back to my first computer, uninstalled Psychopy 1.82.01 and installed 1.84.02 and tried the exact same experiment - which is just to set the parallel port value to 255 at port address 0xD000.
I used to builder GUI which was translated by PsychoPy itself and I got this error:

pyo version 0.8.0 (uses single precision)
Traceback (most recent call last):
File “D:\MyExperiments\Noas\testParallel.py”, line 69, in
p_port = parallel.ParallelPort(address=‘0xD020’)
AttributeError: ‘module’ object has no attribute ‘ParallelPort’

When I manually edited the “ParallelPort” command (which was written by the builder!) to “setPortAddress” (which is older command) I got error on the next commands:

pyo version 0.8.0 (uses single precision)
Traceback (most recent call last):
File “D:\MyExperiments\Noas\testParallel.py”, line 96, in
if t >= 0.0 and p_port.status == NOT_STARTED:
AttributeError: ‘NoneType’ object has no attribute ‘status’

What could cause it and how can I have the exact same code run on my computer just as on my other computer ??

Thanks!
Noa

In the end I did download inpout32.dll and put it in the same directory where the experiment it.
I still wonder how in my old computer the parallel port was working fine without the inpout32.dll file.
But at least it works now.

In addition to (re)installing inpout.dll (installer from http://www.highrez.co.uk/Downloads/InpOut32/) I also needed to compile the script (not run it through Builder) and have the dll in the same directory as the compiled script.