psychopy.org | Reference | Downloads | Github

Remove info dialog on online experiments

URL of experiment: openIAT [PsychoPy]

Description of the problem: I am trying to remove the info dialog box, so that when you run the experiment you will get directly into the test.

I have un-checked the “show info dialog” and it works perfectly in builder, what am I doing wrong?

did you re-sync the experiment?

yes, also tried manually export the html files and uploaded them to gitlab,
also did other changes that synced successfully

For online studies we don’t support the complete absence of the dialog box - there needs to be some time for resources to download and we do want the user to press OK before the study starts. But you can have the fields pre-populate by adding them to the URL like this

  URL_to_my_study/index.html?participant=PARTICIPANT&session=001

e.g. for your study I then get this:

Jon, that would be perfect! but where do I add this to the URL? I am not able to change the URL via the experiment dashboard.

Hi!

I was trying to do exactly this and of course failed. But most importantly, my PsychPy refuses to open the settings now and run the experiment with error message. I unticked it and removed both (pressing the minus) participant and session field.

filename = thisDir + os.sep + u’data/%s%s_%s’ % (expInfo[‘participant’], expName, expInfo[‘date’])
KeyError: ‘participant’

How do I restore the settings? :slight_smile:

As you’ve discovered, it’s important not to remove all the experiment info variables.
When I did this, I think I ended up copying the experiment routine by routine to another blank one. However, since experiment files are plain text I think you should be able to add <Param name="Experiment info" updates="None" val="{'participant': ''}" valType="code"/> to the Settings in a text editor.

Best wishes,

Wakefield

I’m trying to set participant and session, so that all the participant sees is the resource download bar and the ok/cancel buttons (like Jon’s post above). But the participant field always seems to require an entry (see image). What should I do to get rid of it?

EDIT: I figured it out. ?participant=10101010&session=001 needs to be changed to &participant=10101010&session=001

If that’s while piloting, you will probably need to change it back to ? when you go live. The key is that there should be exactly one ? (before the first variable name) in the URL.

2 Likes