psychopy.org | Reference | Downloads | Github

PsychoPy3 crashes at startup


#1

Hi everyone,

I have installed PsychoPy3 on my Windows 10 computer, first from the Anaconda prompt and then again as a standalone version.
When I try running the standalone version, the coder window opens, then immediately disappears again. Upon doing it from the console, the same thing happens and I get the following output:

C:\Users\Marcel Graetz>"C:\Program Files (x86)\PsychoPy3\python.exe" -m psychopy.app.psychopyApp
Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy3\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "C:\Program Files (x86)\PsychoPy3\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py", line 104, in <module>
    main()
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py", line 100, in main
    start_app()
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py", line 28, in start_app
    app = PsychoPyApp(0, showSplash=showSplash)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 190, in __init__
    self.onInit(testMode=testMode, **kwargs)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 331, in onInit
    self.showBuilder(fileList=exps)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 518, in showBuilder
    self.newBuilderFrame()
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 504, in newBuilderFrame
    fileName=fileName, app=self)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py", line 1052, in __init__
    self.makeToolbar()
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py", line 1145, in makeToolbar
    settingsBmp = wx.Bitmap(join(rc, 'cogwindow%i.png' % tbSize), PNG)
wx._core.wxAssertionError: C++ assertion "wxString::Format("%.3f", 1.23).find(str) != wxString::npos" failed at ..\..\src\common\intl.cpp(1648) in wxLocale::GetInfo(): Decimal separator mismatch -- did you use setlocale()?If so, use wxLocale to change the locale instead.
Error in atexit._run_exitfuncs:
wx._core.wxAssertionError: C++ assertion "GetEventHandler() == this" failed at ..\..\src\common\wincmn.cpp(478) in wxWindowBase::~wxWindowBase(): any pushed event handlers must have been removed

Can anyone tell me what I have to do?
Thanks in advance for your help!

Best,
Marcel


#2

Hi @mgraetz, have you tried the troubleshooting page on the PsychoPY website? It is possible that your preferences are somehow corrupt, as they are involved with setting the Bitmap for the Builder window. Try cleaning prefs and app data and let us know if you still cannot get PsychoPy to start.


#3

Hi dvbridges,
thanks for the reply. I looked at the cleaning prefs post again now and get the following:

C:\Program Files (x86)\PsychoPy3>python -c "from psychopy import prefs; print(prefs.paths['userPrefsDir'])"
C:\Users\Marcel Graetz\AppData\Roaming\psychopy3

That seems like a reasonable place for the preference files.
However, if I go there, I find a folder ‘monitors’ containing one file ‘testMonitor.json’, and a folder ‘pavlovia’ containing ‘user.json’ and ‘projects.json’ but no other files, specifically not the preference files that are supposed to be there.

Does that help somehow?


#4

@mgraetz, what standalone version of PsychoPy did you try to install?


#5

I got this file from the GitHub repository:

https://github.com/psychopy/psychopy/releases/download/3.0.3/StandalonePsychoPy3-3.0.3-win32.exe


#6

Great thanks. When I google this error, it comes up as relating to an error with your locale and decimal separators. If you go to Control Panel > Region > Additional Settings… what is the locale, and what is the decimal symbol?


#7

Decimal symbol: ‘.’
List separator: ‘,’

But I do recall that I changed that manually at some point because my system language is German and I was so annoyed by the German number formatting.


#8

Ok, perhaps then the locale is set to German and PsychoPy expects a certain format, which has now changed. Try changing your decimal back to German (comma?) decimal formatting and see if that works.


#9

Thanks a lot, that actually worked.

But it seems that the error only occurs on first startup or something because after changing the system language to English and then trying out a few combinations of English and German language and number formatting, I am now in the same configuration as in the beginning (English language, German number format). However, I can now start the coder view and only get the error when I want to switch to the builder.


#10

Also, it would probably be nice to fix this ‘bug’ at some point, because there are probably many people in Germany who change there number format to English because of the annoying inconvenience when reading in .csv files and similar things.