PsychoPy not uploading to Pavlovia


This issue probably has a really simple correction, but I have tried reading through other discussions, and troubleshooting, but have had no luck.

I have two versions of an experiment that run fine in PsychoPy.

I uploaded Version A into Pavlovia, and copied the files into a new folder (minus the .git folders), and created a version B of the experiment. I ran the version B a couple of times in PsychoPy with no issue.

However, when I try to upload Version B to Pavlovia, it comes up with the ‘This file doesn’t have an existing project’, which I can hit ok. When the second pop up box comes up with the name and source file, the ‘ok’ button is greyed out, so it isn’t giving me the option to upload. I’ve tried restarting the computer and PsychoPy, logging in and out of Pavlovia. Does anyone know how to fix this issue?

Thank you

Have you put the second file in the same folder as the first one? That doesn’t work for Pavlovia.

Thanks for the suggestions, I made a separate folder and copied the relevant files over, and checked that the experiment was running fine from that folder