psychopy.org | Reference | Downloads | Github

PsychoPy library not getting installed coder view

I am trying ti install PsychoPy library in my MacBook so that I can import it in my IDE and use PsychoPy in coder view. However I get this error :
ERROR: Cannot install psychopy==1.90.0, psychopy==1.90.1, psychopy==1.90.2, psychopy==1.90.3, psychopy==2020.1.0, psychopy==2020.1.1, psychopy==2020.1.2, psychopy==2020.2.0, psychopy==2020.2.1, psychopy==2020.2.10, psychopy==2020.2.2, psychopy==2020.2.3, psychopy==2020.2.4, psychopy==2020.2.4.post1, psychopy==2020.2.5, psychopy==2020.2.6, psychopy==2020.2.7, psychopy==2020.2.8, psychopy==2021.1.0, psychopy==2021.1.1, psychopy==2021.1.3, psychopy==2021.1.4, psychopy==2021.2.0, psychopy==2021.2.2, psychopy==2021.2.3, psychopy==3.0.0, psychopy==3.0.1, psychopy==3.0.2, psychopy==3.0.3, psychopy==3.0.4, psychopy==3.0.6, psychopy==3.0.7, psychopy==3.1.0, psychopy==3.1.2, psychopy==3.1.3, psychopy==3.1.4, psychopy==3.1.5, psychopy==3.2.0, psychopy==3.2.2, psychopy==3.2.3 and psychopy==3.2.4 because these package versions have conflicting dependencies.

The conflict is caused by:
psychopy 2021.2.3 depends on tables
psychopy 2021.2.2 depends on tables
psychopy 2021.2.0 depends on tables
psychopy 2021.1.4 depends on tables
psychopy 2021.1.3 depends on tables
psychopy 2021.1.1 depends on tables
psychopy 2021.1.0 depends on tables
psychopy 2020.2.10 depends on tables
psychopy 2020.2.8 depends on tables
psychopy 2020.2.7 depends on tables
psychopy 2020.2.6 depends on tables
psychopy 2020.2.5 depends on tables
psychopy 2020.2.4.post1 depends on tables
psychopy 2020.2.4 depends on tables
psychopy 2020.2.3 depends on tables
psychopy 2020.2.2 depends on tables
psychopy 2020.2.1 depends on tables
psychopy 2020.2.0 depends on tables
psychopy 2020.1.2 depends on tables
psychopy 2020.1.1 depends on tables
psychopy 2020.1.0 depends on tables
psychopy 3.2.4 depends on tables
psychopy 3.2.3 depends on tables
psychopy 3.2.2 depends on tables
psychopy 3.2.0 depends on tables
psychopy 3.1.5 depends on tables
psychopy 3.1.4 depends on tables
psychopy 3.1.3 depends on tables
psychopy 3.1.2 depends on tables
psychopy 3.1.0 depends on tables
psychopy 3.0.7 depends on tables
psychopy 3.0.6 depends on tables
psychopy 3.0.4 depends on tables
psychopy 3.0.3 depends on tables
psychopy 3.0.2 depends on tables
psychopy 3.0.1 depends on tables
psychopy 3.0.0 depends on tables
psychopy 1.90.3 depends on tables
psychopy 1.90.2 depends on tables
psychopy 1.90.1 depends on tables
psychopy 1.90.0 depends on tables

To fix this you could try to:

  1. loosen the range of package versions you’ve specified
  2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit User Guide - pip documentation v21.3.dev0