psychopy.org | Reference | Downloads | Github

Cant install psychoPy in Python3 (Mac)

importing
python3
installation

#1

Hello, I’m trying to install psychopy on python3 on mac but I get an error:
pip3 install psychopy
Collecting psychopy
Using cached PsychoPy-1.84.2.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/private/var/folders/39/88clnp910zlg54lrgy0d7qm40000gn/T/pip-build-ddca2hwz/psychopy/setup.py”, line 28, in
exec(vStr)
File “”, line 42, in
File “/private/var/folders/39/88clnp910zlg54lrgy0d7qm40000gn/T/pip-build-ddca2hwz/psychopy/psychopy/init.py”, line 47, in
from psychopy.tools.versionchooser import useVersion, ensureMinimal
File “/private/var/folders/39/88clnp910zlg54lrgy0d7qm40000gn/T/pip-build-ddca2hwz/psychopy/psychopy/tools/versionchooser.py”, line 19, in
from psychopy import logging, tools, web
File “/private/var/folders/39/88clnp910zlg54lrgy0d7qm40000gn/T/pip-build-ddca2hwz/psychopy/psychopy/web.py”, line 13, in
import httplib
ImportError: No module named ‘httplib’

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /private/var/folders/39/88clnp910zlg54lrgy0d7qm40000gn/T/pip-build-ddca2hwz/psychopy/

Tried to install “httplib” but no luck there also:
pip3 install httplib
Collecting httplib
Could not find a version that satisfies the requirement httplib (from versions: )
No matching distribution found for httplib

Someone knows how should I install it?

Thanks


#2

Did you read the documentation on installation?
http://psychopy.org/installation.html

We’re currently working on Py3 compatibility. The repository version at github is nearly there but not quite ready for primetime. e.g. see some of the issues here (wx4 is needed for PY3 app to run and wx4 introduces various additional compatibility issues):


#3

Yeah I read it. I’m trying to use psychopy in the code not as a package (“from psychopy import core, visual , event”).
The problem is not with code compatibility but with the installation itself.
The import line produce the following error:
ImportError: No module named 'psychopy’
and when I’m trying to pip install it I get the httplib error


#4

Hi, can you please help? Still haven’t figured out how to work psychopy on python3
Thanks


#5

You’re trying to install PsychoPy v 1.84 into Python3 though. That isn’t possible.
As I said above, you need the current repository version from github, not a released version.

BUT if you’re not very experienced with Python I strongly recommend you DONT use the repository version or Python3 yet. It is CERTAIN to contain bugs and only suitable for experienced developers to test things out. If you want to run experiments and have them work then you should use the latest released version with Python2.7