PsychoPy (2022.1.1) doesn't show my Pavlovia projects

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): MacOSX 12.2.1 & Win11
PsychoPy version (e.g. 1.84.x): 2022.1.1
Standard Standalone? (y/n) If not then what?: y
What are you trying to achieve?:
Sync my Pavlovia projects to local computer.

What did you try to make it work?:
I tried to log in with my Pavlovia account, and I logged in successfully.

What specifically went wrong when you tried that?:
My projects didn’t show in the search for project online window. I clicked the Me icon, nothing shows up in the list below.

What’s your username in Pavlovia? Could you link to some of the projects which you should be able to see?

username is nx

I don’t know what do you mean by “link to some projects”. I don’t see any project shown up. This never happened before.

Also, when I tried to launch online studies on local computer (run PsychoJS in local debug mode), it stays at “initialize…” The same program was running fine yesterday before I upgraded to 2022.1.1

I can confirm that even I downgraded to PsychoPy 2021.2.3, the issue remains. Seems to be a Pavlovia server issue.

If you got to and click on the dashboard, could you copy a link to one of your projects from there and share it? That way I can know what projects the requests Builder sends should be returning so can figure out why they aren’t being returned

This is the project that I’m the Maintainer: Pavlovia


The username in that project is Fang. Have you changed your username on Pavlovia?

No. This is my student’s project, which I am the Maintainer. I had no problem to see this project in PsychoPy before. But all I can see now, is a blank list.

I can’t view it either, presumably because it’s set to Private. Can you see it on Pavlovia? If so then the problem is most likely with supplying your user token to the search API - when requesting the project details from Pavlovia, PsychoPy sends a token so that Pavlovia knows that you’re logged in and that you have access to the project. What’s most likely happening is that Pavlovia isn’t recognising your token as one which has sufficient access to view that project.

The API is new (previously we were just using GitLab, which is well established but was extremely slow when searching for large numbers of projects) so it may be that we just need to add a check for whether you’re a maintainer as well as just whether you’re the owner.


The project is Private, and I can see it in Pavlovia along with my other projects. In PsychoPy, I don’t see the projects that I’m the owner (as I said, it’s a complete blank list).

Even with the project that I just created in PsychoPy, I can push changes to GitLab, but still don’t see it anywhere in the project list.

It looks like an API issue. Is there a way I can address this, like reset the token?

On a second thought, even when I tried to use PsychoPy (2021.2.3), the issue remains. I don’t think the 2021.2.3 uses the new API.

Thanks again!

In the project on the website, if you click “View Code” it will take you to the GitLab page for the project. In the top right corner there’s a “Clone” button - click it to open a drop-down menu and copy the “Clone with HTTPS” value.

If you download the GitHub desktop app:

You can use this to clone the project: Go to File → Clone Repository, then choose URL and copy the project’s “Clone with HTTPS” value from earlier. This will copy it all to the folder you specify and will keep it linked to the Pavlovia project in the same way as if you’d got it by clicking “Sync” in PsychoPy (it’s actually the same process behind the scenes). If you make changes in PsychoPy, just open the GitHub desktop app again and click “Sync” to update the project.

Okay. that should work for me but might be too complicated for others (students).

I’m expecting an update in the future to address this issue in PsychoPy?