Psychopy 2021.2.3-1 fails to start

I recently upgraded to Python 3.10.2 on Arch Linux and now Psychopy 2021.2.3-1 crashes on start up with:

  ...
  File "/usr/lib/python3.10/site-packages/macropy/activate.py", line 4, in <module>
    macropy.activate()
  File "/usr/lib/python3.10/site-packages/macropy/__init__.py", line 18, in activate
    from .core import hquotes  # noqa
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1002, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 945, in _find_spec
  File "/usr/lib/python3.10/site-packages/macropy/core/import_hooks.py", line 147, in find_spec
    code, tree = self.expand_macros(source, origin, spec)
  File "/usr/lib/python3.10/site-packages/macropy/core/import_hooks.py", line 113, in expand_macros
    return compile(tree, filename, "exec"), new_tree
TypeError: required field "lineno" missing from alias

I am running macropy version 1.1.0b2 and import macropy.activate gives the same error. This seems to be the latest version of macropy, but there is a bug report from a year ago that macropy does not work with Python 3.8+. I am pretty sure I used Psychopy with Python 3.8 and 3.9, so I am lost.

I feel like I am missing something obvious.

Is this the standalone version installed from PsychoPy.org?

No, it is essentially an install built from the 2021.2.3 source tarball (https://github.com/psychopy/psychopy/archive/2021.2.3.tar.gz) using python setup.py install

Looking into it more, my guess is it is related to the fact that the recommended Python version is 3.6 (which is now past end of life) and that 3.10 is just not supported. I am installing now into a virtual environment with Python 3.9 and checking to see if PsychoPy will pass all the unit tests.