Problems uploading an online experiment

URL of experiment: Sign in · GitLab

Hi, everyone!

I recently finished creating my experiment locally, and now I’m trying to upload it online…

The name of the project I created on Pavlovia: “moment”
The name of the experiment I created in Psychopy: “RT-CIT (Imbar Mizrahi)”

I’m facing some problems, my folders were not created correctly (I think).

When I created the project on Pavlovia the following files:
~ RT-CIT (Imbar Mizrahi)-legacy-browsers.js
~ RT-CIT (Imbar Mizrahi).js
~ index.html
were created inside a folder named: “index.html” and not as part of all the files (as I’ve seen before in others experiments).

After that, I got the following error:
the server responded with a status of 404 ()
Somewhere it was written that it is looking for the files in the “lib” folder, which should be in the “index.html” folder.
I looked for the “lib” folder but it didn’t exist. After a while (I don’t know how), the “lib” folder suddenly appeared but in a different place so I moved it into the “index.html” folder.

Now I get the following error:

In the console it says that the file should exist in the “index.html” folder:

But there is no such file :frowning:

Unfortunately, it seems like my whole project was created in a very messy way, contrary to everything I’ve seen in videos and tutorials (even though I followed all the instructions).

In addition, I think I’m missing (or haven’t created) critical files, for example: “jspsych.css” and “jspsych.js”

***I tried to create new projects with new experiments but these errors keep coming back again and again

I would be grateful if you could help me (this is for my thesis) :pray: :pray: :pray:


Hi! I have the same problem (working on my thesis, as well :)) and I found a workaround that is not ideal at all but it works. First, compile the experiment to js script (the button in the builder) and then push it to pavlovia. Then the files appear in the experiment folder where they should and not in an index.html folder. Good luck with your experiment!

Hi Ann,
First, thank you very much for your response!

I think my main problem is with permissions, when I try to compile the experiment to js script on the button in the builder (I just already tried to do it) I keep getting the following error:
PermissionError: [Errno 13] Permission denied: 'C:\\Users\\imbar\\Documents\\hayom\\index.html'

Have you encountered this before?

Thank you, :pray:

Hi @Imbar_Mizrahi , I’m not sure if I had exactly the same error but what might help is to delete everything in your experiment folder on your computer except your .psyexp file and your resources folder and then try again what I described above.

Hi dear Ann,

First, thank you! your advice helped me a lot!

I followed your advice and I extracted the files from the “index.html” folder to the general folder and deleted this folder.
At first it didn’t work for me. Probably the problem was the js file (in the original experiment). I noticed in the console that it was looking for './lib/psychojs-2022.2.2.js' (it looked like the js file was written based on v2022.2.2 version), while other files were in v2022.0.3 version.

While trying to fix the problems, I changed several versions and everything got too messy :woman_facepalming:

In the end I had to rebuild the experiment (in a different version, i.e., v2022.2.4). Eventually everything went well :slight_smile:

Thank you!