psychopy.org | Reference | Downloads | Github

Please help with setting up feedback

OS (e.g. Win10): MacOS Catalina
PsychoPy version (e.g. 1.84.x): PsychoPy3
**What are you trying to achieve?: Hi. I’m new to PsychoPy I’m trying to set up a basic experiment that requires feedback after each response. I’ve followed the online guidance but struggling to make it work. The experiment runs fine at the moment, but iwhen the feedback should appear on screen there is no text - just a blank screen. I’m inserting screenshots below (hoping they show up in the post…) to show what I have created in the builder. I’m tearing my hair out trying to figure out where I’m going wrong, and would really approeciate any advice/a solution!

You’ve got the text set to “constant” - meaning it gets set at the start of the experiment and stays that way. If you’re updating it later, you need to set it to “Set each repeat” or “Set each frame”

Thank you so much - it’s working perfectly now. Clearly a rookie error!

1 Like

Hello again. I’m afraid I have another request for help in relation to my original post…

The experiment has been set up in the builder and works a treat. However, when I upload it to Pavlovia the feedback no longer works - I once again have blank screens instead of correct/incorrect.

I’ve been searching the forum for similar posts and not been able to find a solution yet. I’ll keep looking, but perhaps there’s something obvious I need to do to fix this? I’d be extremely grateful for any advice.