Pavlovia doesnt update changes

URL of experiment: taskV2 [PsychoPy]

Description of the problem:
To test certain features i have text appear on the screen
expInfo[‘session’] does not appear. i’ve tried simpler text like ‘helo world’ which also doesnt appear
i try printing out in the console and it doesnt appear as well.
I tried adding loops and it doesnt appear

My other experiments do update without a problem.

There is only a single branch so its not a problem of the changes being stored in a different branch.

I clear cache/data and keep refreshing my browser. I made sure git is fully up to date.

Any ideas why nothing new is being updated?

Which textbox should “hello world” be in? Are you able to either make the experiment public so I can view the code or share the .psyexp file here?

Hi @TParsons thanks so much, sharing it here

taskV2.psyexp (748.8 KB)
text_27 and text_31 are not displaying, and a loop did not work either

Hmm, when I use the :compile_js: Compile JS button in Builder and look through the resulting .js file, I can see references to text_27 and text_31, but when I look at the .js file which the experiment is using on Pavlovia there’s no such references. So this suggests a problem syncing - when you sync from Builder, do you get any errors? Does the sync dialog appear and give the usual “Successful sync happened at etc etc etc” message?

Yea i sync from the command line or from psychopy and dont see any errors either way yet no updates occur

Ah that’ll explain it - when you sync from Builder, before syncing the experiment script is written from the Builder experiment. You can do this manually by clicking the :compile_js: Compile JS button. If you sync from the command line, then it’s only syncing the .psyexp file and whatever state the .js file is in from the last time it was :compile_js: compiled. Try compiling your script before syncing, or just syncing direct from Builder.

I also press the sync js button prior to syncing yet that hasn’t helped.

Once you’ve compiled it, does the file taskV2.js open in Coder? If you use CTRL + F in Coder, can you find any reference to text_27 in there?

Hi Todd, thanks again for you help.

Yes I open JS Console and do find text_27 in there. Yet still nothing in pavlovia

Could it be that I am using a bad version of psychopy? i have v2022.1.1

But i scared of having additional issues with the experiment if i update

I would recommend that you upgrade to 2022.1.4 (for maximum compatibility and bug fixes).

upgrading to 1.4 did not solve this issue.

i tried deleting and recreating the text component to no avail.

If you’re syncing from the command line then it won’t be to do with your version of PsychoPy. Are you getting any confirmation back from the terminal that your sync was successful? Are the changes to taskV2.js definitely staged and committed?

I do get confirmation that sync was successful. and generally i am told that 3 files were changed and committed which only occurs if i first stage taskV2.js

If you download that file from Pavlovia (via the GitLab interface) and compare it to the local file, are they different?

when I search for text_27 in the js file that is on pavlovia- it is there as well, yet the text does not appear. The latest commit is indeed reflective of when i last tried to commit a chance (yesterday afternoon)

is there a specific comparison you would like me to make?

I could create a whole new experiment by deleting the .git file etc… but we already paid for participants to complete the experiment with the specified link which we cannot change mid experiment (on prolific)

You can create a new copy of the local files without changing the location of the online files. Whenever I create a demo, I make it in my Wake Gitlab namespace, fork it to vespr, delete the original local files and then sync to a recreated folder from the vespr namespace (because you can only create a new experiment in your main namespace).

Sorry a bit of a novice here and dont know git well enough so didnt 100% follow
Are you suggesting i create a new folder and copy over the experiment and then commit it as a different branch to the current namespace?

No – create a new folder and search for the files from Gitlab via the magnifying glass icon. To use the existing namespace you need to get the files from there, not locally.