Pavlovia Dashboard Error: 502 Bad Gateway

Description of the problem:

Hi everyone,
I got an error when uploading my study on Pavlovia called:

“\r\n502 Bad Gateway\r\n<body bgcolor=“white”>\r\n

502 Bad Gateway


It also says that I should try and contact an administrator.
Is there anybody here who could help me?

Thank you in advance,



I got the same error when I tried to run a study in both of our Pavlovia accounts. Also, when a participant was completing a tasks, it did not saved. Moreover, when I tried to access my accounts, I got this error:
Error when authenticating the experiment designer:


Yes, me too, and my experiments/accounts have been running successfully for months until today. A Pavlovia-wide error perhaps?


Can confirm, had the same issue with a participant just now! None of my experiments are working and I get the 502 Bad Gateway error message.


I have the same problem. The study was running fine until now I received a message from a participant that the link does not work. And I get the same error when trying to access my dashboard.

1 Like

I’ve run into a similar issue ~ was running fine up until about 20 minutes ago. Now I can’t access my experiment or my account.

1 Like

This is hitting us too. Please bear with us while we investigate.


Same problems here!

1 Like

Same here!

1 Like

Same here, sitewide for Cardiff Uni.

1 Like

Same here!

1 Like

Thank you for your actions. Could you inform us, when it should be fine again?

1 Like

Adding @Mel499 to this topic. I am unlisting repetitions of the same error so information is concentrated here.

1 Like

I think that this error also means that no experiments on Pavlovia are currently able to run.



Same error here! Hope it gets fixed soon

Good afternoon,

The pavlovia server experienced a sudden, very substantial burst of activity, possibly linked to a rogue experiment or series of experiments.
With my apologies, we are now back on. And I am investigating the matter in detail.
Best wishes,



Thank you Alain, I can confirm that I can access my dashboard and run my experiments.


Hi, my experiment is now running but recent changes have not been incorporated. I just pushed them again but there is no change (have tried clearing cached files which typically works). Could this be related to this error?

edit: nevermind, it resolved itself!

1 Like

Hi Alain,
Thank you for looking into it more.
I had been running a study through prolific yesterday but none of the data got saved even-though the participants mentioned reaching the end of the study. Most of them received the following error:
504 Gateway Time-out nginx
This is a lot of data and money lost. Is there any way it could be recovered? Or any suggestion as to the best course of action.
Thank you.