psychopy.org | Reference | Downloads | Github

Pavlovia can't find stimuli images

Hi all!
For some reason, I can’t make Pavlovia recognize the images of the food that are supposed to be presented in the experiment. It doesn’t create a corresponding folder in the html/resources folder, so the experiment doesn’t run at all. However, if you copy the stimuli inside the resources folder, it now starts loading components but still crashes immediately after the start giving a message indicating that the images are still not found.
I was thinking that it has to do with the fact that the first time the images are used in the code it’s inside a lengthy conditional statement, but I’m getting more positive that it’s not the issue. There are also 200 images, so maybe Pavlovia just doesn’t work with such quantities? Not sure.
Here is the psyexp file, but it won’t work without the images obviously, so here is also a link to download the entire folder from my Mega cloud - link
portion.psyexp (28.7 KB)
If anyone manages to make to work on Pavlovia - please let me know how you managed to do such a miracle.
Thanks in advance!

Hey! Try not exporting to an html folder. To achieve this, in experiment settings, online tab, leave output path empty

Hi! That’s how I originally did it, but then it doesn’t even create a proper project on Pavlovia, so there is nothing to run. Or am I don’t something wrong?

Ultimately this results in the same problem - Pavlovia doesn’t even start loading the images.

Could you share your experiment so that I can take a peek? My gitlab username is tpronk. See Searching for experiments on Pavlovia — PsychoPy v2021.2

I think I did, but I’m not sure :slight_smile:
The psyexp file is also in the first message (as well as the link to download the entire folder with images included).

Just a little heads-up: I’m moving from one country to the other at the moment. Once I’m settled down, I’ll take a look

I took a look. I think PsychoJS has trouble finding out what stimuli to download because they are set via a code component instead of your conditions file (conds.csv). An easy workaround is as follows: In experiment properties, online tab, add all your pictures to “online resources”

Thanks for looking into this! Unfortunately, this workaround helped only partially - the experiment now loads the images initially (same effect as adding an HTML output folder in the settings), but once the experiment actually begins - images cannot be accessed. I’ve added this change to the project I shared with you too. What could be the cause of this?
image

Try changing the backslashes (\) in your code component to slashes (/)

Yeeeeeeeeeeessssssssss! It worked! Thank you so much!

Woopwoop! :slight_smile: