psychopy.org | Reference | Downloads | Github

Online experiment - black screen after participants information

URL of experiment: https://gitlab.pavlovia.org/marinaChrysikopoulou/english-a

Description of the problem:
Experiment name: EnglishA
Hi, I am pretty new in Psychopy and I’m trying to run an online experiment.
The experiment starts in the piloting version, asks for participants information but afterwards the screen gets black and nothing happens.

The experiment consist of a Raven’s and a priming test and it has a video at the beginning.

If you open your browser’s JavaScript console (in Chrome this can be found by going to View -> Developer), does it give you an error message when this happens?

yes, I get this error:

core-3.2.js:1060 {origin: “MovieStim.setMovie”, context: “when setting the movie of MovieStim: movie”, error: “the argument: �! ���������J�� �a�…���������������������������� is not a video” }"}

Ah, wrong kind of movie file. Right now, for playing videos, you want to use files that have h264 encoding saved as .mp4 files. You will need to re-export your movie in that format and update the movie component to use the new file.

I changed the file on my builder and tried to sync it with the online version however I got a message that says “None points to a remote that doesn’t exist (deleted?). What shall we do?” (Re)create a project…
Do you know why this is happening?

Copying the project and creating a new repository is probably the easiest option.

@apitiot git is being weird again.

sorry if it’s a dumb question, but how can i do this? locally on my computer or online?

Just save-as the experiment in builder, and then create a new repository. If that doesn’t work you may need to delete the old repository, but we can do that if this doesn’t work.

it worked thank you very much !
now I have another problem as it does not recognize the code ‘msg’ that I have on the builder.
I get this error : ReferenceError: msg is not defined

I guess the component has not been translated in javascript right?

Yes, it looks like a code component for the begin routine section of the feedback trial was not translated. You should be able to just open it in the builder, set the type to Auto->JS, save, and re-sync. Make sure the rest of your code components are also set to Auto->JS as well.

Thank you,
even though I have chosen the version 2020.1 on the settings , the Auto–> Js option is not available.
How can this be solved?

When you open the code component there should be a “code type” dropdown menu that lets you select Auto->JS for that code component.

I only have those 3 options.

I would re-install the most recent version of PsychoPy, because that should absolutely be there.