On Excel "key_resp.rt" the timing response

If the timing response is > 1, it does not appear not like 1.23 but as a huge number ex. 123955783939828. Instead when it is < 1 it appears as 0.23431…
How can I fix it? is it possible?

This is likely something to do with the localisation/internationalisation settings on your computer (e.g. whether decimal separators are set to be points or commas). Try opening this file in a plain text editor and see what the numbers look like there (it won’t do any interpretation of the raw text, although it can be hard to read if the columns don’t line up).

The line of least resistance may be to change your system settings to use a decimal point as the decimal separator.


An alternative to Michael’s suggestion is to use OpenOffice or LibreOffice to open the result file. These office programs are smarter than MS-Office in interpreting column delimiters and decimal separators.

notepad++ (win only) is a text editor that allows you to replace all column delimiters and decimal separators in all open files at once.

Best wishes, Jens

It would be even better if PsychoPy would “respect” the localisation settings of the computer it is running on :wink: