psychopy.org | Reference | Downloads | Github

Nothing but background after start, no demos working either

#1

Windows 10 64-bit
PsychoPy 3.0.6 and 3.0.7
Standard Standalone

Hello everyone. I’m a beginner at using this software and I’m currently using it to do a stroop task in a small but important experiment for my master thesis in lighting design testing the effect peripheral discomfort glare might have on task performance.

I have been under a lot of time pressure to get the whole setup ready and tested psychopy before I started getting it to work and thinking it would be the least of my problems. But now I am starting and the test I created won’t run and it’s making me panic a bit.

First it gave me some error codes I could try to figure out but I decided just to rebuild and that seemed to work it out. Then I used the rebuild test for a day.

When I wanted to use it the next day, the rebuild one didn’t work either, but now it gives no error codes. It seems like it’s just presenting the background screen ofthe test. In my test I have a grey background and in the demo stroop it probably have black, or at least that’s what it shows. I can’t get out of the background after this and I can’t get the task manager to appear and close the program. I can see it has opened when I flip through the windows when tab, but it won’t pop up. My soloution is to press ctrl+alt+delete and sign out and sign in again, but this appears to restart the computer or something which is unusual. All programs closes and internet connection restarts (my VPNs tries to reconnect).

As mentioned, the demo works the same way, indicating it is not my test but psychopy itself which is in the wrong, so I tried to uninstall (probably 3.0.6) and reinstall (recently published 3.0.7) standalone version found in the link at the top of the installation page. I also reinstalled python from their webpage. But, it is still doing the same thing with both my test and the demos. It’s not sending to another display either, which I checked. If I run a demo which is not in full-screen mode then I can get PsychoPy to the front and press the red stop button which then closes the only-background-window.

I have no clue what is going on and I’m afraid even rebuilding the test won’t work anymore. I’m in the middle of my testing period and I can’t get it to work. I’m a little stressed out. Hope you can help.

0 Likes

#2

Hi @Mads, its a bit difficult to figure out what is going on, more information is needed. Are you trying to run your task locally on your desktop machine, or are you trying to run your experiment in a web browser from Pavlovia?

0 Likes

#3

Hi. I know it is, but unfornunately there is no error and I’m highly suspecting me to have done something wrong during installation or somewhere else.

I’m running it locally on my laptop and in the experiment just duplicating the screen to a monitor. Everything has worked perfectly but it’s like when my computer is shut down or restarted my tests are not able to run.

As written I have not installed anything but what latest stable release links to and use the “StandalonePsychoPy3-3.0.7-win64” installer. I just reinstalled python as a safety but it worked the other without having done this.

Unfortunately, I cannot remember the lines it failed to execute the other day when it failed. I think it was something about monitor and RGB saying something like “AttributeError: ‘Nonetype’ object has no attribtue close” or/and "typeerror unsupported operand type(s) for * ‘nonetype’ and ‘int’ " but it doesn’t say that now.

I can’t even press escape and quit the experiement like it used to be able to. The only thing which can close the experiment is pressing the stop button but if in fullscreen, only ctrl+alt+delete and signing out works and that seems to be the quickest way to do it.

Hope that elaborated a bit. I’m very happy for the relatively quick respond. Thank you.

0 Likes

#4

I made a WeTransfer link to my two .psyexp files: https://we.tl/t-Lm4m768uy6

But as said I suspect my program to be at fault not the experiment themselves.

Stroop v.1 is the files that gave me the mentioned error codes while Stroop v.2 is now doing this.

Both worked in the windows session/uptime they were created and didn’t work when a new session was started as after a restart or shut down.

0 Likes

#5

Thanks for sharing the psyexp file, would you mind also providing me with the csv conditions file so I can attempt to run the experiment? You should be able to upload them here as an attachment.

0 Likes

#6

Here is a link to the folder with conditions: https://we.tl/t-aVfm9d0K9D

Its basically copies of the same file but they couldn’t be named the same in the way I built the experiment.

0 Likes

#7

Thanks, but would you mind just attaching the csv/excel conditions file here?

0 Likes

#8

conditions_7.xlsx (11.3 KB)

Sorry, of course.

Here is the condition. It’s the same used in all loops. Originally I have them named “conditions_1” to “conditions_14” and “conditions_benchmark_1” and “conditions_benchmark_2” but for some reason it will only name it “conditions_7” no matter which one I drag over here.

0 Likes

#9

I believe your error is the result of setting your screen color in your experiment settings to None. If you want a grey background, set the color in Experiment Settings > Screen tab to $[0,0,0].

0 Likes

#10

I think it has always been $[0,0,0]. I haven’t changed it so it seems to be default. I just checked it on my laptop and it was set to that. I also just installed everything on my desktop and it also has that setting and the experiment works. That would make it a problem with my laptop it would seem. Guess I have to transport my monster stationary to school then.

And by the way, the rest of the experiment was built by following a tutorial by Jon Peirce on youtube (https://www.youtube.com/watch?v=VV6qhuQgsiI)

0 Likes

#11

Ok, well it was giving me an error. Are you trying to run your experiment remotely?

0 Likes

#12

Remotely? Over the internet? I want to run it locally on a machine so it’s as simple as possible for me. I haven’t had too much time on my hand to learn a whole lot about the program.

0 Likes

#13

I just wondered because you mentioned VPNs, and having to get yourself to the school, I thought perhaps you were attempting to run an experiment over a VPN by logging into your schools computer from home.

In the version of the experiment you gave me, I received an error because the screen color was set to None. If you can find an error message that may be of help, let us know and we can figure out what is going on.

0 Likes

#14

I just mentioned the VPNs because it seemed like a crash when trying to reconnect. Maybe I have just been a bit panicked and looking for reasons.

I think I will transport my desktop to school and run everything on that and leave whatever is going wrong behind. I understand it’s difficult to help much without error messages but it really doesn’t give any.

Thank you very much for your help even though it didn’t lead to much.

0 Likes

#15

try pushing the “Compile script” button on the toolbar and then run the experiment from the code window that it switches to (i.e. run it from the Coder rather than Builder view. This should make error messages more apparent.

0 Likes

#16

I have tried that. It hard to explain, but it’s not like something is going wrong in that sense. It runs the program but nothing but a grey screen shows up. It actually looks a little darker grey than what the experiment uses. The program can’t be quited if in fullscreen except signing out but if in a window it is only possible to close by pressing the stop button. Meanwhile the coder shows no error in the output. In the picture below it has been run two times.

What should be shown here is a brighter grey screen with the white introduction text. I can post that later.

0 Likes