psychopy.org | Reference | Downloads | Github

Not finding parameter in conditions file when it is there

URL of experiment: Pavlovia

Description of the problem:

This is a new one. I’ve updated the conditions file for a loop. It has one parameter called ‘environ_practice’. As can be seen below, the dialogue box seems to acknowledge this:

image

The inner layer loop then tries to access that parameter:

image

When I run it online, I receive a ReferenceError: environ_practice not defined.

I have checked, and the sync seems to have worked correctly, with the correct conditions file being in the GitLab repository. When I look at the console in the browser the error points to the line that defines environ_practice, so that makes sense, Here’s a screen shot of the console error and the line of code in the debugger:


Any ideas why it is not picking up on the parameter?

I’ve been away from this for a month or so now, and haven’t done the latest update (too scared that something in my code may not be compatible with any of the changes) - could it be anything to do with that?

Thanks,
Anthony

Hi @Anthony, to help with debugging I will need a minimum working example of the task which shows the error. Currently, the task is taking a long time to find the error.

You might want to use a forward slash / instead of the Windows-only backslash \ in the relative path to the conditions file, although I would have thought that would lead to an error earlier in the process.

1 Like

Hi @dvbridges,

Strangely I can’t recreate the error. It was occuring as recently as Friday, but without really changing anything it is no longer showing the error.

@Michael - thanks for the suggestion. As noted above, the error has disappeared. But thought I’d let you know that I’ve been using the backslash previously without issues. But I’ll take your advice on board and change it so it doesn’t cause problems on other machines.

Cheers,
Anthony

Great, well if you use conditions files in the loop with backslashes, the file paths should be converted correctly to forward slash on compile.

Hi again @dvbridges,

Something weird seems to be happening. I’ve made some pretty major changes but when I try to pilot it, none of them have been implemented, despite the html on the gitlab page reflecting the changes I’ve made.

For example, I have completely deleted the instructions routine so that I can get straight to the parts I’ve been having problems with, but when I pilot it I am still seeing the instruction pages coming up.

I look at the html, and it reflects the fact that there is no longer a routine called ‘Instructions_1’, yet I’m still seeing the pages that that routine used to define. There is nothing in the Coder output to suggest there were problems with compiling either. I called the last commit ‘minimal’, and that seems to be the code which is present. Any ideas where it could be getting the old version from?

It explains why nothing I’ve tried recently has made a difference to the issue I’ve been trying to fix - because it hasn’t been using the updated code!

Cheers,
Anthony

@Anthony, could you please try refreshing your browser cache and trying again? E.g., on Windows you press Shift + F5 with your browser open.

@dvbridges, that did the trick, thanks

1 Like