psychopy.org | Reference | Downloads | Github

Not able to browse my excel parameters onto my psychopy loop

OS (e.g. Win10): MacOS version 10.14.5
PsychoPy version (e.g. 1.84.x): v3.1.2

What are you trying to achieve?:
I am trying to make the dot probe paradigm. We are having trouble uploading the excel sheet to psychopy.

What did you try to make it work?:

i tried to add .jpeg after the picture names, I tried changing double quote marks to single quote marks on the excel sheet.

What specifically went wrong when you tried that?:

the parameters did not get browsed on psychopy.

Include pasted full error message if possible. “That didn’t work” is not enough information.

Hey Amanat, not sure if I can help you but have had the same problem a couple of times and was able to work it out. Could you upload the file or a screenshot of it so I can see if you have any of the same formatting issues I had before?

Yes, thanks a ton!

alicia_test_2.xlsx (11.5 KB)

Hello again, sorry, I’ve looked and tried a few things (you could try some too, maybe it’ll magically work) but unfortunately I get the same error (as I outlined here a few days ago). As said there, this could be a bug; what has finally worked for me somehow was making new files and trying to import the excel file there, and the not-so-great task of making endless changes or new excel files in hopes of it catching on.

Some formatting things: sometimes if cells are right-outlined (you have a few) it doesn’t work, and I would delete/rewrite all left, right cells so that they don’t contain any apostrophes anymore (double check if the left one is actually deleted). Hope you get it figured out and if you do please let me know what did it! Sorry I couldn’t help further.

Thanks a lot!! This is really helpful :slight_smile:

Hi Amanat,

The problem is that you’re using one variable name twice, namely p1locationy. I suspect this should be p2locationy.

Jan

P.S. And you might want to remove the quotes around your correct responses.

1 Like

Okay I’ll try that, thanks a ton!