No longer receiving a message on Experiment Runner at the end (when downloaded 2020.2)

Hello everyone. I have been reading here (thanks for the community!) and this is my first post.
After running an experiment on builder (offline), there always was some kind of information (warning, errors etc.) in the Experiment Runner page that shows up. Now that I downloaded the latest version (Psychopy 2020.2), there never is any kind of information. I don’t see any error message even when the experiment stopped working. Always there is this line only:

####### Running: C:\Users\zadiguzel13\Desktop\Recency\ #######

What can do to fix this? I should be able to receive warning or error mesages, or any kind of message other than what is above. (I am using win10)
Thank you!

That’s strange, it definitely should be printing on experiment end. Have you tried resetting your preferences to default?

Thank you for your comment. Yes I found it strange too. After your comment, I checked the preferences, useRunner is already checked in General menu. Also in Application menu, default view contains Builder, Coder and Runner option. Are these what you are referring to as resetting preferences to default?

There is an option to reset all preferences, in the Application settings if you tick “reset preferences” then it will reset everything to default when you next open Psychopy

I tried twice but nothing changed. Also when I hit the sync button, I receive this error. Can it be relatable because of stdOut? Interestingly, the same experiment used work in Pavlovia in previous version of Psychopy.

This is a known bug, it happens when you click the sync without having Runner open. I’ve added the fix on GitHub and it will be in the next release. However, are you getting this error when Runner is open? If so it may be that, for whatever reason, it does not recognise your Runner window as the stdOut to send output to…

1 Like

Thank you very much. As you said, I didn’t have Runner open. But when I have Runner open, now I got this error (picture below). I searched for this error and found this previous forum post

What do you recommend I should do? Should I switch to a previous version (because I need to start data collection very soon)
Thank you for your time!

This is another which we have fixes for ready to go out with 2020.2.3, so I think yes, downgrading to the last version is the best bet until 2020.2.3

Understood. Thank you very much for your help! My last question is that which particular version should I downgrade, the latest version without these bugs?
I was thinking this version, but wanted to check with you.
Thank you,

Definitely the latest version without these bugs! Try 2020.1 and see if that works